xwin-xdg-menu is not showing menu in taskbar

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

xwin-xdg-menu is not showing menu in taskbar

Volker Quetschke
Well, it is showing up with two processes in the windows task manager,
with one consuming 15% or so of the CPU, but the icon never appears in
the task bar.

The system is a fresh install of cygwin 64 bit version on a new laptop -
see attached cygcheck.out.

To reproduce this the x server is started with the "XWin Server" entry
under "Cygwin-X" on the Start Menu.

The menu actually worked for me in the beginning and I managed to
pinpoint what broke it. Originally I had only xorg-server, xinit and
xclock installed. That worked, the x server and the menu came up
quickly, but xclock complained about missing fonts. So I installed the 6
xorg-x11-fonts-* packages. That broke it.

I uninstalled the six fonts again and reinstalled them one after the
other. With all except
    xorg-x11-fonts-ethiopic
installed the menu keeps working as expected. No, I didn't try yet if
the ethiopic font breaks it again when I install it.

   Volker

--
PGP/GPG key  (ID: 0x9F8A785D)  available  from  wwwkeys.de.pgp.net
key-fingerprint 550D F17E B082 A3E9 F913  9E53 3D35 C9BA 9F8A 785D

--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple

cygcheck.out (125K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: xwin-xdg-menu is not showing menu in taskbar

Brian Inglis
On 2020-10-09 09:53, Volker Quetschke wrote:

> Well, it is showing up with two processes in the windows task manager, with one
> consuming 15% or so of the CPU, but the icon never appears in the task bar.
>
> The system is a fresh install of cygwin 64 bit version on a new laptop - see
> attached cygcheck.out.
>
> To reproduce this the x server is started with the "XWin Server" entry under
> "Cygwin-X" on the Start Menu.
>
> The menu actually worked for me in the beginning and I managed to pinpoint what
> broke it. Originally I had only xorg-server, xinit and xclock installed. That
> worked, the x server and the menu came up quickly, but xclock complained about
> missing fonts. So I installed the 6 xorg-x11-fonts-* packages. That broke it.
>
> I uninstalled the six fonts again and reinstalled them one after the other. With
> all except
>    xorg-x11-fonts-ethiopic
> installed the menu keeps working as expected. No, I didn't try yet if the
> ethiopic font breaks it again when I install it.

I just managed to restore X-Win functionality by renaming ~/.startxwinrc and
running the following commands, which I have now installed in permanent
postinstall scripts, to ensure that mime type and icon caches are updated:

$ head /etc/postinstall/zp_[ac]*.dash
==> /etc/postinstall/zp_all-icon-themes.dash <==
#!/bin/dash
# zp_all-icon-themes.dash - rebuild all icon theme caches where index exists

if [ -x /usr/bin/gtk-update-icon-cache ]
then
    for index in /usr/share/icons/*/index.theme \
                /usr/*/sys-root/*/share/icons/*/index.theme
    do
        dir=${index%/*}
        /usr/bin/gtk-update-icon-cache --force $dir || :

==> /etc/postinstall/zp_cache-shared-mime-info.dash <==
#!/bin/dash
# zp_cache-shared-mime-info.dash - rebuild shared mime info caches

[ -x /usr/bin/update-mime-database ] && [ -d /usr/share/mime ] && \
    /usr/bin/update-mime-database /usr/share/mime || :

You might also want to force rebuild the font cache by running:

        $ /etc/postinstall/zp_fontconfig_cache_1.sh

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in binary units and prefixes, physical quantities in SI.]
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: xwin-xdg-menu is not showing menu in taskbar

Achim Gratz
Brian Inglis writes:
> I just managed to restore X-Win functionality by renaming ~/.startxwinrc and
> running the following commands, which I have now installed in permanent
> postinstall scripts, to ensure that mime type and icon caches are updated:

It would be more generally helpful if we'd be able to figure out what
conditions need to trigger these updates so the corresponding packages
could be fixed accordingly.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Factory and User Sound Singles for Waldorf Q+, Q and microQ:
http://Synth.Stromeko.net/Downloads.html#WaldorfSounds
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: xwin-xdg-menu is not showing menu in taskbar

Brian Inglis
On 2020-10-21 11:01, Achim Gratz wrote:
> Brian Inglis writes:
>> I just managed to restore X-Win functionality by renaming ~/.startxwinrc and
>> running the following commands, which I have now installed in permanent
>> postinstall scripts, to ensure that mime type and icon caches are updated:
>
> It would be more generally helpful if we'd be able to figure out what
> conditions need to trigger these updates so the corresponding packages
> could be fixed accordingly.

The package and permanent postinstall scripts attempt to set trigger conditions
to conditionally rebuild caches as required, but that obviously is not always
effective, so I did my own forced complete cache rebuilds, and added that to my
local permanent postinstall scripts.

[I should flag the names as local with e.g. [0z]p_l_...dash, as I already have
some flagged zp_z#_...dash to restart services and run postinstall as background
tasks to log rebase -is and cygcheck -hrsv, update man-db caches, and for
zoneinfo to add extra aliases and replace identical zone files with links.]

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in binary units and prefixes, physical quantities in SI.]
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple