windres VERSIONINFO not working

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

windres VERSIONINFO not working

Paul J. Lucas
        I'm trying to use gcc and windres to build a small native
        Windows application.  When compiling, I'm using -mno-cygwin;
        when linking, I'm using -mwindows.  To generate a .res file from
        a .rc file, I'm using:

                windres -O coff $< $@

        in my makefile.  Everything seems to work and the generated
        executable also shows its icon as specified in the .rc file, but
        there's no version information tab in Windows explorer.  My .rc
        file is below.

        Any ideas why this doesn't work and how to make it work?

        - Paul

#include <windows.h>

My_Icon ICON MyIcon.ico

My_Version VERSIONINFO
    FILEVERSION     1,0,5,0
    PRODUCTVERSION  1,0,5,0
    FILEFLAGSMASK   0
    FILEFLAGS       0
    FILEOS          VOS__WINDOWS32
    FILETYPE        VFT_APP
    FILESUBTYPE     0
    {
        BLOCK "StringFileInfo"
        {
            BLOCK "0x040904E4"          // U.S. English + Windows
            {
                VALUE "CompanyName", "My Company, Inc."
                VALUE "FileDescription", "Best application ever"
                VALUE "FileVersion", "1.0.5"
                VALUE "InternalName", "WIdget"
                VALUE "LegalCopyright", "Copyright \251 2005 Me."
                VALUE "OriginalFilename", "Widget.exe"
                VALUE "ProductName", "Widget"
                VALUE "ProductVersion", "1.0.5"
            }
        }
        BLOCK "VarFileInfo"
        {
            VALUE "Translation", 0x0409,0
        }
    }

/* vim:set et sw=4 ts=4: */

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/