setup 2.886 release candidate - please test

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

setup 2.886 release candidate - please test

Jon TURNEY

A new setup release candidate is available at:

   https://cygwin.com/setup/setup-2.886.x86.exe    (32 bit version)
   https://cygwin.com/setup/setup-2.886.x86_64.exe (64 bit version)

Since this contains many internal changes, I think this could use some
wider testing before being deployed. Please test and report any problems
here.

This is not the place for setup feature requests.

Changes compared to 2.885:
- Apply default problem solutions in unattended mode
- Make --include-source work correctly in unattended mode
- Allow parser to accept an empty depends: list (2.885 (only) will
report syntax errors when parsing setup.ini containing these, when the
corresponding change to calm is deployed)
Reply | Threaded
Open this post in threaded view
|

Re: setup 2.886 release candidate - please test

Achim Gratz
Jon Turney writes:
> A new setup release candidate is available at:
>
>   https://cygwin.com/setup/setup-2.886.x86.exe    (32 bit version)
>   https://cygwin.com/setup/setup-2.886.x86_64.exe (64 bit version)

Locally compiled, but not well tested yet.

> Changes compared to 2.885:
> - Apply default problem solutions in unattended mode
> - Make --include-source work correctly in unattended mode
> - Allow parser to accept an empty depends: list (2.885 (only) will
> report syntax errors when parsing setup.ini containing these, when the
> corresponding change to calm is deployed)

Do you have an idea yet why the last package gets orphaned (or did, if
it's already fixed)?  I will need to remove my workaround of placing an
empty dummy at the end to try.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Waldorf MIDI Implementation & additional documentation:
http://Synth.Stromeko.net/Downloads.html#WaldorfDocs
Reply | Threaded
Open this post in threaded view
|

Re: setup 2.886 release candidate - please test

Jon TURNEY
On 01/02/2018 20:21, Achim Gratz wrote:

> Jon Turney writes:
>> A new setup release candidate is available at:
>>
>>    https://cygwin.com/setup/setup-2.886.x86.exe    (32 bit version)
>>    https://cygwin.com/setup/setup-2.886.x86_64.exe (64 bit version)
>
> Locally compiled, but not well tested yet.
>
>> Changes compared to 2.885:
>> - Apply default problem solutions in unattended mode
>> - Make --include-source work correctly in unattended mode
>> - Allow parser to accept an empty depends: list (2.885 (only) will
>> report syntax errors when parsing setup.ini containing these, when the
>> corresponding change to calm is deployed)
>
> Do you have an idea yet why the last package gets orphaned (or did, if

'Yet'?  This is the first time I've heard of this!

Is this regression?

> it's already fixed)?  I will need to remove my workaround of placing an
> empty dummy at the end to try.

I guess you are saying that the last package listed in setup.ini appears
as orphaned, when you have a re-written setup.ini which only contains
one version per package?

Which I can easily believe happens, due to the rather weird way that the
data from a parser reduction is transferred into the package database.
Reply | Threaded
Open this post in threaded view
|

Re: setup 2.886 release candidate - please test

Achim Gratz
Jon Turney writes:
>> Do you have an idea yet why the last package gets orphaned (or did, if
>
> 'Yet'?  This is the first time I've heard of this!

Right you are.  I thought I had mentioned it already, but forgot since I
can't post from work.

> Is this regression?

Yes.

>> it's already fixed)?  I will need to remove my workaround of placing an
>> empty dummy at the end to try.
>
> I guess you are saying that the last package listed in setup.ini
> appears as orphaned, when you have a re-written setup.ini which only
> contains one version per package?

I've tested that again today.  The last package gets orphaned if there
is only a current section.  I believe that the last section is also not
processed, so in the standard Cygwin installation you'd not be able to
see the previous version of _update-info-dir.

> Which I can easily believe happens, due to the rather weird way that
> the data from a parser reduction is transferred into the package
> database.

All my packages only have a single (curr) version in the rewritten
setup.ini as I have different setup.ini files (or rather directories
they are in) for keeping older states of the installation around.  Some
of the processing seems to be associated with seeing the start of a new
package or a new section as I can make it process the last package
correctly if I either start a dummy package with absolutely no content
(just the "@ packagename" line) or a dummy section (either [prev] or
[test] works, again with no content).



Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

SD adaptations for Waldorf Q V3.00R3 and Q+ V3.54R2:
http://Synth.Stromeko.net/Downloads.html#WaldorfSDada
Reply | Threaded
Open this post in threaded view
|

Re: setup 2.886 release candidate - please test

Jon TURNEY
On 02/02/2018 19:38, Achim Gratz wrote:

> Jon Turney writes:
>>> Do you have an idea yet why the last package gets orphaned (or did, if
>>
>> 'Yet'?  This is the first time I've heard of this!
>
> Right you are.  I thought I had mentioned it already, but forgot since I
> can't post from work.
>
>> Is this regression?
>
> Yes.
>
>>> it's already fixed)?  I will need to remove my workaround of placing an
>>> empty dummy at the end to try.
>>
>> I guess you are saying that the last package listed in setup.ini
>> appears as orphaned, when you have a re-written setup.ini which only
>> contains one version per package?
>
> I've tested that again today.  The last package gets orphaned if there
> is only a current section.  I believe that the last section is also not
> processed, so in the standard Cygwin installation you'd not be able to
> see the previous version of _update-info-dir.
>
>> Which I can easily believe happens, due to the rather weird way that
>> the data from a parser reduction is transferred into the package
>> database.
Can you test the attached patch, please?


0001-Make-sure-we-process-the-last-version-description-in.patch (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: setup 2.886 release candidate - please test

Achim Gratz
Jon Turney writes:
>>> Which I can easily believe happens, due to the rather weird way that
>>> the data from a parser reduction is transferred into the package
>>> database.
>
> Can you test the attached patch, please?

Thanks, this works for the last package problem, although I can't
account for all the possible corner cases that may exist elsewhere.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Factory and User Sound Singles for Waldorf Q+, Q and microQ:
http://Synth.Stromeko.net/Downloads.html#WaldorfSounds