"non-unique current versions" error from calm

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

"non-unique current versions" error from calm

Mark Geisert
I tried uploading my re-spin of util-linux (2.33.1-2) but received the
following error report on both x86_64 and x86 uploads:

ERROR: install packages from source package 'e2fsprogs' have non-unique
current versions 2.33.1-2 (uuidd), 1.44.5-1 (4 others)

I see it's talking about sub-packages of util-linux, but ISTM that even
the prior upload of 2.33.1-1 long ago should have provoked this error.

I've looked around a bit locally in hopes of figuring this out, but no
luck.  I can't tell if this is something I could/should fix with a manual
"version: 2.33.1-2" added to the appropriate hint files before upload, or
something that needs fixing or cleanout on sourceware.

Any leads appreciated...  Thanks!

..mark
Reply | Threaded
Open this post in threaded view
|

Re: "non-unique current versions" error from calm

Jon TURNEY
On 14/04/2020 00:01, Mark Geisert wrote:
> I tried uploading my re-spin of util-linux (2.33.1-2) but received the
> following error report on both x86_64 and x86 uploads:
>
> ERROR: install packages from source package 'e2fsprogs' have non-unique
> current versions 2.33.1-2 (uuidd), 1.44.5-1 (4 others)
>
> I see it's talking about sub-packages of util-linux, but ISTM that even
> the prior upload of 2.33.1-1 long ago should have provoked this error.

This check is getting confused by the fact that install package uuidd
has moved from source package e2fsprogs to source package util-linux.

I've added an exception for the moment, but perhaps I need to rethink
how that test works.

Sorry for the inconvenience.