"ls -la /dev" fails to write output

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

"ls -la /dev" fails to write output

Cygwin list mailing list
Hi,

Under cmd.exe listing /dev doesn't produce output. Running under strace
also fails with the following errors:

304  477235 [main] ls 8268 fhandler_console::write: 0x8000990F0, 54
126  477361 [main] ls 8268 seterrno_from_win_error:
../../../../winsup/cygwin/fhandler_console.cc:1810 windows error 6
110  477471 [main] ls 8268 geterrno_from_win_error: windows error 6 ==
errno 9
115  477586 [main] ls 8268 fhandler_console::write_normal: write failed,
handle 0x190
 97  477683 [main] ls 8268 write: -1 = write(1, 0x8000990F0, 54), errno 9

Thanks,
Kacper
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: "ls -la /dev" fails to write output

Cygwin list mailing list
On Sat, 16 May 2020 20:39:57 +0200
Kacper Michajlow via Cygwin <[hidden email]> wrote:

> Hi,
>
> Under cmd.exe listing /dev doesn't produce output. Running under strace
> also fails with the following errors:
>
> 304  477235 [main] ls 8268 fhandler_console::write: 0x8000990F0, 54
> 126  477361 [main] ls 8268 seterrno_from_win_error:
> ../../../../winsup/cygwin/fhandler_console.cc:1810 windows error 6
> 110  477471 [main] ls 8268 geterrno_from_win_error: windows error 6 ==
> errno 9
> 115  477586 [main] ls 8268 fhandler_console::write_normal: write failed,
> handle 0x190
>  97  477683 [main] ls 8268 write: -1 = write(1, 0x8000990F0, 54), errno 9

I cannot reproduce your problem. Could you please provide
step by step procedure to reproduce your problem?

--
Takashi Yano <[hidden email]>
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: "ls -la /dev" fails to write output

Cygwin list mailing list
On Sat, 16 May 2020 at 21:04, Takashi Yano <[hidden email]> wrote:

> I cannot reproduce your problem. Could you please provide
> step by step procedure to reproduce your problem?


I though I lost it, because indeed there is prerequisite. It fails when
there is at least one pty allocated.

STR:
1. Open mintty (will allocate pty)
2. Open cmd with Cygwin's bash
3. ls -la /dev will fail in cmd.

-Kacper
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: "ls -la /dev" fails to write output

Cygwin list mailing list
On Sat, 16 May 2020 21:46:54 +0200
Kacper Michajlow via Cygwin <[hidden email]> wrote:

> On Sat, 16 May 2020 at 21:04, Takashi Yano <[hidden email]> wrote:
>
> > I cannot reproduce your problem. Could you please provide
> > step by step procedure to reproduce your problem?
>
>
> I though I lost it, because indeed there is prerequisite. It fails when
> there is at least one pty allocated.
>
> STR:
> 1. Open mintty (will allocate pty)
> 2. Open cmd with Cygwin's bash
> 3. ls -la /dev will fail in cmd.

Thanks for the report. The problem does not occur in
cygwin 3.1.4, but occurs in the current git head.

I have just submit a patch for this issue.

--
Takashi Yano <[hidden email]>
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple