lftp version override help

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

lftp version override help

Andrew Schulman
As I described elsewhere here, I'm trying to dump lftp 4.8.0-1, which is
partly broken, and promote 4.7.8-1 to current. I thought I could do that by
uploading override.hint with:

prev: 4.7.7-1
curr: 4.7.8-1
test: 4.7.8-1

But calm doesn't like that:

ERROR: package 'lftp' version '4.8.0-1' is most recent non-test version,
but version '4.7.8-1' is curr:
ERROR: package 'lftp-debuginfo' version '4.8.0-1' is most recent non-test
version, but version '4.7.8-1' is curr:
ERROR: error while validating merged x86 packages for Andrew Schulman

So I guess I need a manual intervention. Can someone please help?

Thanks,
Andrew

Reply | Threaded
Open this post in threaded view
|

Re: lftp version override help

Ken Brown-6
On 10/11/2017 1:14 PM, Andrew Schulman wrote:

> As I described elsewhere here, I'm trying to dump lftp 4.8.0-1, which is
> partly broken, and promote 4.7.8-1 to current. I thought I could do that by
> uploading override.hint with:
>
> prev: 4.7.7-1
> curr: 4.7.8-1
> test: 4.7.8-1
>
> But calm doesn't like that:
>
> ERROR: package 'lftp' version '4.8.0-1' is most recent non-test version,
> but version '4.7.8-1' is curr:
> ERROR: package 'lftp-debuginfo' version '4.8.0-1' is most recent non-test
> version, but version '4.7.8-1' is curr:
> ERROR: error while validating merged x86 packages for Andrew Schulman
>
> So I guess I need a manual intervention. Can someone please help?

See https://cygwin.com/package-upload.html near the end, under the
heading "Removing files from the Cygwin distribution".

Ken
Reply | Threaded
Open this post in threaded view
|

Re: lftp version override help

Jon TURNEY
On 11/10/2017 18:35, Ken Brown wrote:
> On 10/11/2017 1:14 PM, Andrew Schulman wrote:
>> As I described elsewhere here, I'm trying to dump lftp 4.8.0-1, which is
>> partly broken, and promote 4.7.8-1 to current. I thought I could do
>> that by
>> uploading override.hint with:
>>
>> prev: 4.7.7-1
>> curr: 4.7.8-1
>> test: 4.7.8-1

It's not clear what using the same version as test: and curr: means.

It's not something I considered, so please don't do that.

It probably should be reported as an error.

>> But calm doesn't like that:
>>
>> ERROR: package 'lftp' version '4.8.0-1' is most recent non-test version,
>> but version '4.7.8-1' is curr:
>> ERROR: package 'lftp-debuginfo' version '4.8.0-1' is most recent non-test
>> version, but version '4.7.8-1' is curr:
>> ERROR: error while validating merged x86 packages for Andrew Schulman
>>
>> So I guess I need a manual intervention. Can someone please help?
>
> See https://cygwin.com/package-upload.html near the end, under the
> heading "Removing files from the Cygwin distribution".
  Note that this will not cause setup to automatically downgrade people
to 4.7.8-1 if they have 4.8.0-1 installed.
Reply | Threaded
Open this post in threaded view
|

Re: lftp version override help

Andrew Schulman
> On 11/10/2017 18:35, Ken Brown wrote:
> > On 10/11/2017 1:14 PM, Andrew Schulman wrote:
> >> As I described elsewhere here, I'm trying to dump lftp 4.8.0-1, which is
> >> partly broken, and promote 4.7.8-1 to current. I thought I could do
> >> that by
> >> uploading override.hint with:
> >>
> >> prev: 4.7.7-1
> >> curr: 4.7.8-1
> >> test: 4.7.8-1
>
> It's not clear what using the same version as test: and curr: means.
>
> It's not something I considered, so please don't do that.
>
> It probably should be reported as an error.

OK. I was only trying to dump 4.8.0-1 once and for all.

> >> But calm doesn't like that:
> >>
> >> ERROR: package 'lftp' version '4.8.0-1' is most recent non-test version,
> >> but version '4.7.8-1' is curr:
> >> ERROR: package 'lftp-debuginfo' version '4.8.0-1' is most recent non-test
> >> version, but version '4.7.8-1' is curr:
> >> ERROR: error while validating merged x86 packages for Andrew Schulman
> >>
> >> So I guess I need a manual intervention. Can someone please help?
> >
> > See https://cygwin.com/package-upload.html near the end, under the
> > heading "Removing files from the Cygwin distribution".
>   Note that this will not cause setup to automatically downgrade people
> to 4.7.8-1 if they have 4.8.0-1 installed.

Understood. I'll tell people in the announcement.