lftp 4.8.4-1 upload error

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

lftp 4.8.4-1 upload error

Andrew Schulman
I just uploaded lftp-4.8.4-1 for x86_64, and got these error notices back
from calm:

ERROR: package 'lftp' version '4.8.4-1' is most recent non-test version,
but version '4.7.8-2' is curr:
ERROR: package 'lftp-debuginfo' version '4.8.4-1' is most recent non-test
version, but version '4.7.8-2' is curr:
ERROR: error while validating merged x86_64 packages for Andrew Schulman
SUMMARY: 3 ERROR(s)

I guess this is because we pinned 4.7.8-2 as curr: some time last year,
when I had to forcibly roll back from 4.8.0-1. Is that right? Is this
something you can fix, or do I need to do something?

Thanks,
Andrew

Reply | Threaded
Open this post in threaded view
|

Re: lftp 4.8.4-1 upload error

Jon TURNEY
On 29/08/2018 19:16, Andrew Schulman wrote:

> I just uploaded lftp-4.8.4-1 for x86_64, and got these error notices back
> from calm:
>
> ERROR: package 'lftp' version '4.8.4-1' is most recent non-test version,
> but version '4.7.8-2' is curr:
> ERROR: package 'lftp-debuginfo' version '4.8.4-1' is most recent non-test
> version, but version '4.7.8-2' is curr:
> ERROR: error while validating merged x86_64 packages for Andrew Schulman
> SUMMARY: 3 ERROR(s)
>
> I guess this is because we pinned 4.7.8-2 as curr: some time last year,
> when I had to forcibly roll back from 4.8.0-1. Is that right? Is this
> something you can fix, or do I need to do something?

Correct.

lftp currently has an override.hint containing:

prev: 4.7.7-1
curr: 4.7.8-2
replace-versions: 4.8.0-1

(the last line is an instruction to setup to downgrade any installs of
the withdrawn 4.8.0-1 to 4.7.8-2)

I think all of this isn't needed any more, so you can add an empty
override.hint to your upload to supersede that.

(Possibly you can even add a '-override.hint' to remove it, but I'm not
sure that works :) )

You'll need to do the same thing for lftp-debuginfo as well
Reply | Threaded
Open this post in threaded view
|

Re: lftp 4.8.4-1 upload error

marco atzeri-4
Am 29.08.2018 um 21:15 schrieb Jon Turney:
> On 29/08/2018 19:16, Andrew Schulman wrote:

>
> (Possibly you can even add a '-override.hint' to remove it, but I'm not
> sure that works :) )

usually yes

---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren gepr├╝ft.
https://www.avast.com/antivirus

Reply | Threaded
Open this post in threaded view
|

Re: lftp 4.8.4-1 upload error

Andrew Schulman
In reply to this post by Jon TURNEY
> I think all of this isn't needed any more, so you can add an empty
> override.hint to your upload to supersede that.

Got it. Thanks.

Reply | Threaded
Open this post in threaded view
|

Re: lftp 4.8.4-1 upload error

Andrew Schulman
In reply to this post by Jon TURNEY
> On 29/08/2018 19:16, Andrew Schulman wrote:
> > I just uploaded lftp-4.8.4-1 for x86_64, and got these error notices back
> > from calm:
> >
> > ERROR: package 'lftp' version '4.8.4-1' is most recent non-test version,
> > but version '4.7.8-2' is curr:
> > ERROR: package 'lftp-debuginfo' version '4.8.4-1' is most recent non-test
> > version, but version '4.7.8-2' is curr:
> > ERROR: error while validating merged x86_64 packages for Andrew Schulman
> > SUMMARY: 3 ERROR(s)
> >
> > I guess this is because we pinned 4.7.8-2 as curr: some time last year,
> I think all of this isn't needed any more, so you can add an empty
> override.hint to your upload to supersede that.

OK. So this worked for x86, but for some reason when I upload for x86_64, I get
this back:

ERROR: error while reading uploaded arch x86_64 packages from maintainer Andrew
Schulman

Any idea why? I've rebuilt and uploaded again with the same result.

Thanks,
Andrew

Reply | Threaded
Open this post in threaded view
|

Re: lftp 4.8.4-1 upload error

Jon TURNEY
On 30/08/2018 09:58, Andrew Schulman wrote:

>> On 29/08/2018 19:16, Andrew Schulman wrote:
>>> I just uploaded lftp-4.8.4-1 for x86_64, and got these error notices back
>>> from calm:
>>>
>>> ERROR: package 'lftp' version '4.8.4-1' is most recent non-test version,
>>> but version '4.7.8-2' is curr:
>>> ERROR: package 'lftp-debuginfo' version '4.8.4-1' is most recent non-test
>>> version, but version '4.7.8-2' is curr:
>>> ERROR: error while validating merged x86_64 packages for Andrew Schulman
>>> SUMMARY: 3 ERROR(s)
>>>
>>> I guess this is because we pinned 4.7.8-2 as curr: some time last year,
>> I think all of this isn't needed any more, so you can add an empty
>> override.hint to your upload to supersede that.
>
> OK. So this worked for x86, but for some reason when I upload for x86_64, I get
> this back:
>
> ERROR: error while reading uploaded arch x86_64 packages from maintainer Andrew
> Schulman

Yeah, that's not a very helpful error message :(

> Any idea why? I've rebuilt and uploaded again with the same result.

It seems that the advice I gave was wrong, and that '-override.hint'
works, but an empty 'override.hint' is (silently) considered invalid
(because it uses the same parser as other .hint files, which aren't
expected to be empty)

I've added some output so this failure isn't hidden, and added an item
to improve the hint parser to my calm backlog.

I renamed 'override.hint' to '-override.hint' and set the upload to
retried, which seems to have succeeded.

Sorry for the inconvenience.

Reply | Threaded
Open this post in threaded view
|

Re: lftp 4.8.4-1 upload error

Andrew Schulman
> It seems that the advice I gave was wrong, and that '-override.hint'
> works, but an empty 'override.hint' is (silently) considered invalid
> (because it uses the same parser as other .hint files, which aren't
> expected to be empty)
>
> I've added some output so this failure isn't hidden, and added an item
> to improve the hint parser to my calm backlog.
>
> I renamed 'override.hint' to '-override.hint' and set the upload to
> retried, which seems to have succeeded.

OK, thanks. I did try using -override.hint with x86, but thought it had
failed because of some residual complaints about the old versions that came
back from calm.

Anyway, lftp seems to be back on a regular release course now so I hope I'm
done with override.hint for a while.

Andrew