io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

classic Classic list List threaded Threaded
17 messages Options
Reply | Threaded
Open this post in threaded view
|

io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

Arpitha M
Hi,

We are trying to install cygwin in our 64 bit-OS using 32 bit setup.exe
since we have to support 32 bit machines as well in our product.

In the installation process, after selecting required packages setup.exe is
crashing saying setup.exe has stopped working. I looked into the log from
/var/log/ folder and found the below error:

2020/01/02 12:17:09 io_stream_cygfile: fopen(/etc/setup/setup.rc) failed 2
No such file or directory
2020/01/02 12:17:09 Ending cygwin install

Please guide us to rectify the above issue.

Regards,
Arpitha M

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

marco atzeri-4
Am 03.01.2020 um 06:39 schrieb Arpitha M:

> Hi,
>
> We are trying to install cygwin in our 64 bit-OS using 32 bit setup.exe
> since we have to support 32 bit machines as well in our product.
>
> In the installation process, after selecting required packages setup.exe is
> crashing saying setup.exe has stopped working. I looked into the log from
> /var/log/ folder and found the below error:
>
> 2020/01/02 12:17:09 io_stream_cygfile: fopen(/etc/setup/setup.rc) failed 2
> No such file or directory
> 2020/01/02 12:17:09 Ending cygwin install
>
> Please guide us to rectify the above issue.
>
> Regards,
> Arpitha M
>

questions:

What OS version are you using ?
Have you an Antivirus installed ? Which one ? Anything in its log ?
In which directory are you trying to setup Cygwin ?
Have you tried to setup a 64bit Cygwin ?

Regards
Marco

PS: I put you in CC as I am not sure you have properly subscribed to the
mailing list.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

Arpitha M
Hi,

Please see my below response:

What OS version are you using ?
Windows 8.1 pro (64 bit)

Have you an Antivirus installed ? Which one ? Anything in its log ?
I have disabled my antivirus during installation.

In which directory are you trying to setup Cygwin ?
D drive as it has more space available.

Have you tried to setup a 64bit Cygwin ?
No I have not.

Regards,
Arpitha M

On Fri, Jan 3, 2020 at 11:42 AM Marco Atzeri <[hidden email]> wrote:

> Am 03.01.2020 um 06:39 schrieb Arpitha M:
> > Hi,
> >
> > We are trying to install cygwin in our 64 bit-OS using 32 bit setup.exe
> > since we have to support 32 bit machines as well in our product.
> >
> > In the installation process, after selecting required packages setup.exe
> is
> > crashing saying setup.exe has stopped working. I looked into the log from
> > /var/log/ folder and found the below error:
> >
> > 2020/01/02 12:17:09 io_stream_cygfile: fopen(/etc/setup/setup.rc) failed
> 2
> > No such file or directory
> > 2020/01/02 12:17:09 Ending cygwin install
> >
> > Please guide us to rectify the above issue.
> >
> > Regards,
> > Arpitha M
> >
>
> questions:
>
> What OS version are you using ?
> Have you an Antivirus installed ? Which one ? Anything in its log ?
> In which directory are you trying to setup Cygwin ?
> Have you tried to setup a 64bit Cygwin ?
>
> Regards
> Marco
>
> PS: I put you in CC as I am not sure you have properly subscribed to the
> mailing list.
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

marco atzeri-4
Am 03.01.2020 um 07:15 schrieb Arpitha M:
> Hi,

Hi Arpitha,
post bottom and trim on this mailing list, please.

>
> Please see my below response:
>
> What OS version are you using ?
> Windows 8.1 pro (64 bit)
>
> Have you an Antivirus installed ? Which one ? Anything in its log ?
> I have disabled my antivirus during installation.
>
> In which directory are you trying to setup Cygwin ?
> D drive as it has more space available.

Not a problem. My setup is the same.

>
> Have you tried to setup a 64bit Cygwin ?
> No I have not.
>
> Regards,
> Arpitha M
>

There was recently a similar crash reported

https://cygwin.com/ml/cygwin/2020-01/msg00004.html

can you try to use the test version

      https://cygwin.com/setup/setup-2.899.x86.exe


and see if it solves your problem ?

Regards
Marco

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

Arpitha M
>
> Hi,
>
> Sorry I did not understand what you meant by trim on mailing list.
>
> I tried to install test version but my machine is not allowing and throws
> error "Windows prevented an unrecognized app from starting.Running this app
> might put your PC into risk.
>

Regards,
Arpitha M

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

marco atzeri-4
In reply to this post by marco atzeri-4
Am 03.01.2020 um 08:10 schrieb Arpitha M:

> Hi,
>
> Sorry I did not understand what you meant by trim on mailing list.
>
> I tried to install test version but my machine is not allowing and
> throws error. Attached is the screenshot.
> image.png
> Regards,
> Arpitha M
>

click on "More info" and accept the exception.

Regards
Marco


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

Arpitha M
Hi,

It did not crash this time. Installation is in progress.

Thank you so much for the help.

Will keep you posted.

Regards,
Arpitha M

On Fri, Jan 3, 2020 at 12:48 PM Marco Atzeri <[hidden email]> wrote:

> Am 03.01.2020 um 08:10 schrieb Arpitha M:
> > Hi,
> >
> > Sorry I did not understand what you meant by trim on mailing list.
> >
> > I tried to install test version but my machine is not allowing and
> > throws error. Attached is the screenshot.
> > image.png
> > Regards,
> > Arpitha M
> >
>
> click on "More info" and accept the exception.
>
> Regards
> Marco
>
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

marco atzeri-4
In reply to this post by marco atzeri-4
Am 03.01.2020 um 08:13 schrieb Arpitha M:
> Hi,
>
> Sorry I did not understand what you meant by trim on mailing list.
>

https://www.animalgenome.org/community/angenmap/mail-style.html

see example and note at end of "GOOD: Terse Summary"

Regards
Marco


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

Arpitha M
Hi Marco,

Thanks a lot for the help :)

I have successfully installed cygwin in my machine. While I am trying to
build my client using cygwin, I am encountering below error.

$ make
gcc -I. -I. -g -O2 -DCYGWIN -DHAVE_CONFIG_H -Wall -W -I./open/include  -c
id.c -o id.o
      0 [main] make 6396 child_info_fork::abort:
\??\D:\cygwin\bin\cygiconv-2.dll: Loaded to different address:
parent(0x5D0000) != child(0x440000)
make: fork: Resource temporarily unavailable

Could you please help me resolving this issue?

Thank you in advance.

Regards,
Arpitha M

On Fri, Jan 3, 2020 at 1:12 PM Marco Atzeri <[hidden email]> wrote:

> Am 03.01.2020 um 08:13 schrieb Arpitha M:
> > Hi,
> >
> > Sorry I did not understand what you meant by trim on mailing list.
> >
>
> https://www.animalgenome.org/community/angenmap/mail-style.html
>
> see example and note at end of "GOOD: Terse Summary"
>
> Regards
> Marco
>
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

marco atzeri-4
Am 07.01.2020 um 04:58 schrieb Arpitha M:

> Hi Marco,
>
> Thanks a lot for the help :)
>
> I have successfully installed cygwin in my machine. While I am trying to
> build my client using cygwin, I am encountering below error.
>
> $ make
> gcc -I. -I. -g -O2 -DCYGWIN -DHAVE_CONFIG_H -Wall -W -I./open/include
>   -c id.c -o id.o
>        0 [main] make 6396 child_info_fork::abort:
> \??\D:\cygwin\bin\cygiconv-2.dll: Loaded to different address:
> parent(0x5D0000) != child(0x440000)
> make: fork: Resource temporarily unavailable
>
> Could you please help me resolving this issue?
>
> Thank you in advance.
>
> Regards,
> Arpitha M
>

fork problems are usually caused by programs like:
https://cygwin.com/faq/faq.html#faq.using.bloda


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

Arpitha M
Hi Marco,

I have disabled my AVG antivirus and I do not have any other applications
mentioned in FAQ.

I tried executing /bin/rebase -all, that also gives following error "rebase
too many dlls for availability address space".

I am not sure how to proceed further. Please advise.

Regards,
Arpitha M

On Wed, Jan 8, 2020 at 4:30 AM Marco Atzeri <[hidden email]> wrote:

> Am 07.01.2020 um 04:58 schrieb Arpitha M:
> > Hi Marco,
> >
> > Thanks a lot for the help :)
> >
> > I have successfully installed cygwin in my machine. While I am trying to
> > build my client using cygwin, I am encountering below error.
> >
> > $ make
> > gcc -I. -I. -g -O2 -DCYGWIN -DHAVE_CONFIG_H -Wall -W -I./open/include
> >   -c id.c -o id.o
> >        0 [main] make 6396 child_info_fork::abort:
> > \??\D:\cygwin\bin\cygiconv-2.dll: Loaded to different address:
> > parent(0x5D0000) != child(0x440000)
> > make: fork: Resource temporarily unavailable
> >
> > Could you please help me resolving this issue?
> >
> > Thank you in advance.
> >
> > Regards,
> > Arpitha M
> >
>
> fork problems are usually caused by programs like:
> https://cygwin.com/faq/faq.html#faq.using.bloda
>
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

David Finnie
Hi Arpitha,
> I tried executing /bin/rebase -all, that also gives following error "rebase
> too many dlls for availability address space".

Was that using ash or dash after ensuring that all other cygwin
processes have terminated (including any cygwin terminals that you have
open) ?

> I am not sure how to proceed further. Please advise.

There is a problem that I posted with the latest and greatest cygwin
(3.1.2-1) that is very similar, but not 100% the same. I have resolved
my problem for the moment by reverting to 3.0.7-1, and that has also
worked for another user (although that user did have a problem that was
100% the same as mine). Can I suggest giving that a try ?

Dave


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

ASSI
In reply to this post by Arpitha M
Arpitha M writes:
> I have disabled my AVG antivirus and I do not have any other
> applications mentioned in FAQ.

Disabling AVG does not completely eliminate all of it's strange side
effects or at least with some earlier version it did not.

> I tried executing /bin/rebase -all, that also gives following error "rebase
> too many dlls for availability address space".

Well, don't use a 32bit Cygwin then or at least don't try to install
everything.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Samples for the Waldorf Blofeld:
http://Synth.Stromeko.net/Downloads.html#BlofeldSamplesExtra

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

Arpitha M
In reply to this post by Arpitha M
Hi Marco,

While I am trying to configure I am getting below error:

configure: Configuring id 2.0.0.1
checking build system type... i686-pc-cygwin
checking host system type... i686-pc-cygwin
checking target system type... i686-pc-cygwin
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: in `/cygdrive/e/CLIENT':
configure: error: C compiler cannot create executables
See `config.log' for more details.

Could you please guide me how to resolve this?

Thanks in advance.

Regards,
Arpitha M

On Thu, Jan 9, 2020 at 11:38 AM Arpitha M <[hidden email]> wrote:

> Hi Marco,
>
> I have disabled my AVG antivirus and I do not have any other applications
> mentioned in FAQ.
>
> I tried executing /bin/rebase -all, that also gives following error
> "rebase too many dlls for availability address space".
>
> I am not sure how to proceed further. Please advise.
>
> Regards,
> Arpitha M
>
> On Wed, Jan 8, 2020 at 4:30 AM Marco Atzeri <[hidden email]>
> wrote:
>
>> Am 07.01.2020 um 04:58 schrieb Arpitha M:
>> > Hi Marco,
>> >
>> > Thanks a lot for the help :)
>> >
>> > I have successfully installed cygwin in my machine. While I am trying
>> to
>> > build my client using cygwin, I am encountering below error.
>> >
>> > $ make
>> > gcc -I. -I. -g -O2 -DCYGWIN -DHAVE_CONFIG_H -Wall -W -I./open/include
>> >   -c id.c -o id.o
>> >        0 [main] make 6396 child_info_fork::abort:
>> > \??\D:\cygwin\bin\cygiconv-2.dll: Loaded to different address:
>> > parent(0x5D0000) != child(0x440000)
>> > make: fork: Resource temporarily unavailable
>> >
>> > Could you please help me resolving this issue?
>> >
>> > Thank you in advance.
>> >
>> > Regards,
>> > Arpitha M
>> >
>>
>> fork problems are usually caused by programs like:
>> https://cygwin.com/faq/faq.html#faq.using.bloda
>>
>>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

marco atzeri-4
Am 21.01.2020 um 05:37 schrieb Arpitha M:
> Hi Marco,

Hi Arpitha,


> While I am trying to configure I am getting below error:
>
> configure: Configuring id 2.0.0.1
> checking build system type... i686-pc-cygwin
> checking host system type... i686-pc-cygwin
> checking target system type... i686-pc-cygwin
> checking for gcc... gcc
> checking for C compiler default output file name...
> configure: error: in `/cygdrive/e/CLIENT':
> configure: error: C compiler cannot create executables
> See `config.log' for more details.
>
> Could you please guide me how to resolve this?
>
> Thanks in advance.
>

have you looked on the config.log ?
We can not magically read from your system.

What is this "id" software ? The name is too generic to find
it in the web

Regards





--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

marco atzeri-4
Am 21.01.2020 um 05:58 schrieb Arpitha M:

> Hi Marco,
>
> Complete error as follows:
>
> $ ./configure
> configure: Configuring idevs 2.0.0.1
> checking build system type... i686-pc-cygwin
> checking host system type... i686-pc-cygwin
> checking target system type... i686-pc-cygwin
> checking for gcc... gcc
> checking for C compiler default output file name...
> configure: error: in `/cygdrive/e/CLIENT':
> configure: error: C compiler cannot create executables
> See `config.log' for more details.
>
> Attached is the config log.
>
> Regards,
> Arpitha M
>

Again here we follow bottom posting as guide line.

can you check if you can compile the failing test ?

$ cat prova.c
/* confdefs.h.  */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define IDEVS_VERSION "2.0.0.1"
/* end confdefs.h.  */

int
main ()
{

   ;
   return 0;
}

  $ gcc prova.c -o prova -Wall

  $ ls -s prova
156K prova




--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: io_stream_cygfile: fopen(/etc/setup/setup.rc) failed

ASSI
In reply to this post by Arpitha M
Arpitha M writes:
> configure: error: in `/cygdrive/e/CLIENT':
> configure: error: C compiler cannot create executables
> See `config.log' for more details.

You probably either can't write to that drive or the directory is
mounted with noexec option or some DACL is set so that you can't execute
the resulting file.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Samples for the Waldorf Blofeld:
http://Synth.Stromeko.net/Downloads.html#BlofeldSamplesExtra

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple