grace broken installation

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

grace broken installation

Rodrigo Medina-2
Hi,
Both   installations of grace-5.1.24 and grace-5.1.245 are  broken.
/usr/bin/xmgrace.exe runs but gives the message:
--> Broken or incomplete installation - read the FAQ!
and then quits.

For both versions the link grace-->xmgrace.exe is missing.

For version 5.1.24 by setting
ln -s xmgrace.exe grace
inside /usr/bin the problem is solved.

For version 5.1.25 the problem is not solved by setting the link.
I conclude that there are additional installation errors.
The files /etc/setup/grace.lst.gz of both versions are different.

RM

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: grace broken installation

Hans-Bernhard Bröker
Am 25.01.2020 um 15:23 schrieb Rodrigo Medina:
> Hi,
> Both   installations of grace-5.1.24 and grace-5.1.245 are  broken.
> /usr/bin/xmgrace.exe runs but gives the message:
> --> Broken or incomplete installation - read the FAQ!
> and then quits.

After reading the FAQ and comparing with a direct build from upstream
sources, I find the reason for that is that the FontDataBase file of the
distributed package is, indeed, wrong.

Apparently the type1 font directory supplied by grace was replaced by a
link to ghostscript's type1 font repository.  But the FontDataBase
wasn't updated to match this change.  This mismatch causes xmgrace to
baulk.  This change was made between revisions 5.1.24 and 5.1.25 of the
cygwin package, which neatly explains why 5.1.24 works, but 5.1.25 does not.

> For both versions the link grace-->xmgrace.exe is missing.

This was most likely caused by the cygport file not doing the (rather
unusual) 'make links' step of the original Makefiles, but rather doing
their own tweaking.  The 'grace' link is only created by 'make links'
--- there is no 'grace' created in ${GRACE_HOME}/bin.  I would consider
that an upstream bug, albeit it a small one.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: grace broken installation

Brian Inglis
On 2020-01-26 20:25, Hans-Bernhard Bröker wrote:

> Am 25.01.2020 um 15:23 schrieb Rodrigo Medina:
>> Hi,
>> Both   installations of grace-5.1.24 and grace-5.1.245 are  broken.
>> /usr/bin/xmgrace.exe runs but gives the message:
>> --> Broken or incomplete installation - read the FAQ!
>> and then quits.
>
> After reading the FAQ and comparing with a direct build from upstream sources, I
> find the reason for that is that the FontDataBase file of the distributed
> package is, indeed, wrong.
>
> Apparently the type1 font directory supplied by grace was replaced by a link to
> ghostscript's type1 font repository.  But the FontDataBase wasn't updated to
> match this change.  This mismatch causes xmgrace to baulk.  This change was made
> between revisions 5.1.24 and 5.1.25 of the cygwin package, which neatly explains
> why 5.1.24 works, but 5.1.25 does not.
>
>> For both versions the link grace-->xmgrace.exe is missing.
>
> This was most likely caused by the cygport file not doing the (rather unusual)
> 'make links' step of the original Makefiles, but rather doing their own
> tweaking.  The 'grace' link is only created by 'make links' --- there is no
> 'grace' created in ${GRACE_HOME}/bin.  I would consider that an upstream bug,
> albeit it a small one.

/usr/share/doc/cygwin-doc/html/cygwin-ug-net/using.html#pathnames-symlinks
/usr/share/doc/cygwin-doc/html/cygwin-ug-net/using-cygwinenv.html
https://wiki.samba.org/index.php/UNIX_Extensions#Minshall.2BFrench_symlinks

Because of potential differences from user customization of symbolic link types
thru the CYGWIN environment variable winsymlinks:{lnk,native,nativestrict} and
file system type dependencies, ranging from lack of any symlink support on
CIFS/Samba to real symlinks on NFS, symlinks are created in Cygwin package
postinstall scripts to honour customizations or work around limitations.

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: grace broken installation

Ken Brown-6
In reply to this post by Hans-Bernhard Bröker
On 1/26/2020 10:25 PM, Hans-Bernhard Bröker wrote:

> Am 25.01.2020 um 15:23 schrieb Rodrigo Medina:
>> Hi,
>> Both   installations of grace-5.1.24 and grace-5.1.245 are  broken.
>> /usr/bin/xmgrace.exe runs but gives the message:
>> --> Broken or incomplete installation - read the FAQ!
>> and then quits.
>
> After reading the FAQ and comparing with a direct build from upstream sources, I
> find the reason for that is that the FontDataBase file of the distributed
> package is, indeed, wrong.
>
> Apparently the type1 font directory supplied by grace was replaced by a link to
> ghostscript's type1 font repository.  But the FontDataBase wasn't updated to
> match this change.  This mismatch causes xmgrace to baulk.  This change was made
> between revisions 5.1.24 and 5.1.25 of the cygwin package, which neatly explains
> why 5.1.24 works, but 5.1.25 does not.

See

https://cygwin.com/ml/cygwin/2018-03/msg00142.html
https://cygwin.com/ml/cygwin/2018-03/msg00156.html

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: grace broken installation

Hans-Bernhard Bröker
Am 27.01.2020 um 13:58 schrieb Ken Brown:
> On 1/26/2020 10:25 PM, Hans-Bernhard Bröker wrote:
>> Am 25.01.2020 um 15:23 schrieb Rodrigo Medina:
>>> Hi,
>>> Both   installations of grace-5.1.24 and grace-5.1.245 are  broken.
>>> /usr/bin/xmgrace.exe runs but gives the message:
>>> --> Broken or incomplete installation - read the FAQ!
>>> and then quits.

>> After reading the FAQ and comparing with a direct build from upstream sources, I
>> find the reason for that is that the FontDataBase file of the distributed
>> package is, indeed, wrong.

>> Apparently the type1 font directory supplied by grace was replaced by a link to
>> ghostscript's type1 font repository.  But the FontDataBase wasn't updated to
>> match this change.  This mismatch causes xmgrace to baulk.  This change was made
>> between revisions 5.1.24 and 5.1.25 of the cygwin package, which neatly explains
>> why 5.1.24 works, but 5.1.25 does not.
>
> See
>
> https://cygwin.com/ml/cygwin/2018-03/msg00142.html
> https://cygwin.com/ml/cygwin/2018-03/msg00156.html

Yes, that's about what I figured.  The fonts supplied by xmgrace were
replaced (in the cygport file) by a link to ghostscript's fonts, but
then those were replaced by URW fonts, which broke xmgrace.

OTOH the particular font files xmgrace is looking for are in yet another
place on Cygwin:

     /usr/share/X11/fonts/urw-fonts

And indeed, making the /usr/share/grace/fonts/type1 symlink point there
does appear to fix the breakage.

So the minimal patch to grace.cygport (other than just leaving the type1
directory of xmgrace alone) would be:

$ diff -uwp grace.cygport{~,}
--- grace.cygport~      2017-06-27 09:43:32.000000000 +0200
+++ grace.cygport       2020-01-28 00:08:56.345429500 +0100
@@ -78,7 +78,7 @@ src_install() {
         rmdir doc
         ln -sf ../doc/${NAME} doc
         rm -fr fonts/type1
-       ln -sf /usr/share/ghostscript/fonts fonts/type1
+       ln -sf /usr/share/X11/fonts/urw-fonts fonts/type1
         popd

         make_desktop_entry xmgrace Grace xmgrace
"Education;Science;DataVisualization;Motif"

An additional/changed dependency on the urw-base35-fonts-legacy package
would probably be needed, but I'll have to leave that to people who
understand Cygwin packaging.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: grace broken installation

Brian Inglis
On 2020-01-27 16:24, Hans-Bernhard Bröker wrote:

> Am 27.01.2020 um 13:58 schrieb Ken Brown:
>> On 1/26/2020 10:25 PM, Hans-Bernhard Bröker wrote:
>>> Am 25.01.2020 um 15:23 schrieb Rodrigo Medina:
>>>> Hi,
>>>> Both   installations of grace-5.1.24 and grace-5.1.245 are  broken.
>>>> /usr/bin/xmgrace.exe runs but gives the message:
>>>> --> Broken or incomplete installation - read the FAQ!
>>>> and then quits.
>
>>> After reading the FAQ and comparing with a direct build from upstream sources, I
>>> find the reason for that is that the FontDataBase file of the distributed
>>> package is, indeed, wrong.
>
>>> Apparently the type1 font directory supplied by grace was replaced by a link to
>>> ghostscript's type1 font repository.  But the FontDataBase wasn't updated to
>>> match this change.  This mismatch causes xmgrace to baulk.  This change was made
>>> between revisions 5.1.24 and 5.1.25 of the cygwin package, which neatly explains
>>> why 5.1.24 works, but 5.1.25 does not.
>>
>> See
>>
>> https://cygwin.com/ml/cygwin/2018-03/msg00142.html
>> https://cygwin.com/ml/cygwin/2018-03/msg00156.html
>
> Yes, that's about what I figured.  The fonts supplied by xmgrace were replaced
> (in the cygport file) by a link to ghostscript's fonts, but then those were
> replaced by URW fonts, which broke xmgrace.
>
> OTOH the particular font files xmgrace is looking for are in yet another place
> on Cygwin:
>
>     /usr/share/X11/fonts/urw-fonts
>
> And indeed, making the /usr/share/grace/fonts/type1 symlink point there
> does appear to fix the breakage.
>
> So the minimal patch to grace.cygport (other than just leaving the type1
> directory of xmgrace alone) would be:
>
> $ diff -uwp grace.cygport{~,}
> --- grace.cygport~      2017-06-27 09:43:32.000000000 +0200
> +++ grace.cygport       2020-01-28 00:08:56.345429500 +0100
> @@ -78,7 +78,7 @@ src_install() {
>         rmdir doc
>         ln -sf ../doc/${NAME} doc
>         rm -fr fonts/type1
> -       ln -sf /usr/share/ghostscript/fonts fonts/type1
> +       ln -sf /usr/share/X11/fonts/urw-fonts fonts/type1
>         popd
>
>         make_desktop_entry xmgrace Grace xmgrace
> "Education;Science;DataVisualization;Motif"
>
> An additional/changed dependency on the urw-base35-fonts-legacy package would
> probably be needed, but I'll have to leave that to people who understand Cygwin
> packaging.

Links should only be applied during build processes to allow building and
testing to complete successfully.
Build link types may not be compatible with tar or the target file system and
should not be included in packages for distribution e.g. they may only work on
systems configured for WSL and with WSL installed.
Distributed package links should be generated during post-install processing and
should fall back to file copies if links are unsupported on the target file system.

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: grace broken installation

Ken Brown-6
On 1/28/2020 1:38 AM, Brian Inglis wrote:
> Links should only be applied during build processes to allow building and
> testing to complete successfully.
> Build link types may not be compatible with tar or the target file system and
> should not be included in packages for distribution e.g. they may only work on
> systems configured for WSL and with WSL installed.
> Distributed package links should be generated during post-install processing and
> should fall back to file copies if links are unsupported on the target file system.

Many Cygwin packages contain symlinks that are not generated during
post-install.  setup handles them just fine.

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple