git 2.14.2-1 is faulty

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

git 2.14.2-1 is faulty

Andy Li
Hi,

I've just noticed that the git package 2.14.2-1 is buggy:

$ git clone https://github.com/andyli/HaxeCI.git
Cloning into 'HaxeCI'...
fatal: Unable to find remote helper for 'https'

According to
https://stackoverflow.com/questions/8329485/unable-to-find-remote-helper-for-https-during-git-clone,
probably the package was built without libcurl-devel.

I've only tested x86_64, not sure about x86.

Best regards,
Andy
Reply | Threaded
Open this post in threaded view
|

Re: git 2.14.2-1 is faulty

marco atzeri-4
On 30/09/2017 11:31, Andy Li wrote:

> Hi,
>
> I've just noticed that the git package 2.14.2-1 is buggy:
>
> $ git clone https://github.com/andyli/HaxeCI.git
> Cloning into 'HaxeCI'...
> fatal: Unable to find remote helper for 'https'
>
> According to
> https://stackoverflow.com/questions/8329485/unable-to-find-remote-helper-for-https-during-git-clone,
> probably the package was built without libcurl-devel.
>
> I've only tested x86_64, not sure about x86.
>
> Best regards,
> Andy
>

it works for me

x86_64 $ git clone https://github.com/andyli/HaxeCI.git
Cloning into 'HaxeCI'...
remote: Counting objects: 389, done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 389 (delta 1), reused 4 (delta 1), pack-reused 383
Receiving objects: 100% (389/389), 52.48 KiB | 1.28 MiB/s, done.
Resolving deltas: 100% (212/212), done.

x86_64 $ git --version
git version 2.14.1
Reply | Threaded
Open this post in threaded view
|

Re: git 2.14.2-1 is faulty

Andy Li
x86_64 $ git --version
git version 2.14.1


The issue is about 2.14.2 ;)

Best,
Andy