cygcheck-dep: using depends2

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

cygcheck-dep: using depends2

cygwin-apps mailing list
Hi Mikhail,
can you please update cygcheck-dep to use "depends2:" field values
instead of "requires:"

It is not useful to see one library packages is needed by
predecessors libraries:

$ cygcheck-dep -q -S -N libMagickCore6_6
  libMagickCore6_6: is recursively needed for ( a2ps asciidoc asymptote
autotrace caja-extensions dblatex dmtx-utils feh gnome-common
gnome-exe-thumbnailer gtk-doc html2ps ImageMagick inkscape karbon
latex2rtf libautotrace-devel libautotrace3 libMagick-devel
libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5
libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6
libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5
libwraster6 mate-common perl-Image-Magick psiconv pstoedit
pstoedit-devel WindowMaker xfce4-dev-tools xhtml2ps xmlto zbar )

of course as there are multiples  "depends2:" only the current one
should be used.


Regards
Marco
Reply | Threaded
Open this post in threaded view
|

Re: cygcheck-dep: using depends2

Mikhail Usenko-2
On Thu, 13 Aug 2020 16:01:54 +0200
Marco Atzeri via Cygwin-apps <...> wrote:

> Hi Mikhail,
> can you please update cygcheck-dep to use "depends2:" field values
> instead of "requires:"
>
> It is not useful to see one library packages is needed by
> predecessors libraries:
>
> $ cygcheck-dep -q -S -N libMagickCore6_6
>   libMagickCore6_6: is recursively needed for ( a2ps asciidoc asymptote
> autotrace caja-extensions dblatex dmtx-utils feh gnome-common
> gnome-exe-thumbnailer gtk-doc html2ps ImageMagick inkscape karbon
> latex2rtf libautotrace-devel libautotrace3 libMagick-devel
> libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5
> libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6
> libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5
> libwraster6 mate-common perl-Image-Magick psiconv pstoedit
> pstoedit-devel WindowMaker xfce4-dev-tools xhtml2ps xmlto zbar )
>
> of course as there are multiples  "depends2:" only the current one
> should be used.
>

Hello, Marco.
Sorry for the delay in response.
If it is to completely ignore the "requires:" field, the result is the very same:
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
$ ./cygcheck-dep -V
cygcheck-dep, version 3.1  # <--- modified testing version
$ ./cygcheck-dep -q -S -N libMagickCore6_6
 libMagickCore6_6: is recursively needed for ( autotrace dmtx-utils inkscape karbon libautotrace-devel libautotrace3 libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5 libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6 libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5 libwraster6 psiconv pstoedit pstoedit-devel WindowMaker zbar )

$ cygcheck-dep -V
cygcheck-dep, version 3.0  # <--- current version
$ cygcheck-dep -q -S -N libMagickCore6_6
 libMagickCore6_6: is recursively needed for ( autotrace dmtx-utils inkscape karbon libautotrace-devel libautotrace3 libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5 libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6 libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5 libwraster6 psiconv pstoedit pstoedit-devel WindowMaker zbar )
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-


--

Reply | Threaded
Open this post in threaded view
|

Re: cygcheck-dep: using depends2

cygwin-apps mailing list
On Mon, Aug 31, 2020 at 7:42 AM Mikhail Usenko  wrote:

>
> On Thu, 13 Aug 2020 16:01:54 +0200
> Marco Atzeri via Cygwin-apps <...> wrote:
>
> > Hi Mikhail,
> > can you please update cygcheck-dep to use "depends2:" field values
> > instead of "requires:"
> >
> > It is not useful to see one library packages is needed by
> > predecessors libraries:
> >
> > $ cygcheck-dep -q -S -N libMagickCore6_6
> >   libMagickCore6_6: is recursively needed for ( a2ps asciidoc asymptote
> > autotrace caja-extensions dblatex dmtx-utils feh gnome-common
> > gnome-exe-thumbnailer gtk-doc html2ps ImageMagick inkscape karbon
> > latex2rtf libautotrace-devel libautotrace3 libMagick-devel
> > libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5
> > libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6
> > libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5
> > libwraster6 mate-common perl-Image-Magick psiconv pstoedit
> > pstoedit-devel WindowMaker xfce4-dev-tools xhtml2ps xmlto zbar )
> >
> > of course as there are multiples  "depends2:" only the current one
> > should be used.
> >
>
> Hello, Marco.
> Sorry for the delay in response.
> If it is to completely ignore the "requires:" field, the result is the very same:
> -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
> $ ./cygcheck-dep -V
> cygcheck-dep, version 3.1  # <--- modified testing version
> $ ./cygcheck-dep -q -S -N libMagickCore6_6
>  libMagickCore6_6: is recursively needed for ( autotrace dmtx-utils inkscape karbon libautotrace-devel libautotrace3 libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5 libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6 libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5 libwraster6 psiconv pstoedit pstoedit-devel WindowMaker zbar )
>
> $ cygcheck-dep -V
> cygcheck-dep, version 3.0  # <--- current version
> $ cygcheck-dep -q -S -N libMagickCore6_6
>  libMagickCore6_6: is recursively needed for ( autotrace dmtx-utils inkscape karbon libautotrace-devel libautotrace3 libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5 libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6 libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5 libwraster6 psiconv pstoedit pstoedit-devel WindowMaker zbar )
> -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
>
Hi Mikhail,
Are you considering that there is a depends2 field for every version
and you need to consider only
the actual one ?

Regards
Marco
Reply | Threaded
Open this post in threaded view
|

Re: cygcheck-dep: using depends2

Mikhail Usenko-2
On Mon, 31 Aug 2020 13:30:11 +0200
marco atzeri <...> wrote:

> On Mon, Aug 31, 2020 at 7:42 AM Mikhail Usenko  wrote:
> >
> > On Thu, 13 Aug 2020 16:01:54 +0200
> > Marco Atzeri via Cygwin-apps <...> wrote:
> >
> > > Hi Mikhail,
> > > can you please update cygcheck-dep to use "depends2:" field values
> > > instead of "requires:"
> > >
> > > It is not useful to see one library packages is needed by
> > > predecessors libraries:
> > >
> > > $ cygcheck-dep -q -S -N libMagickCore6_6
> > >   libMagickCore6_6: is recursively needed for ( a2ps asciidoc asymptote
> > > autotrace caja-extensions dblatex dmtx-utils feh gnome-common
> > > gnome-exe-thumbnailer gtk-doc html2ps ImageMagick inkscape karbon
> > > latex2rtf libautotrace-devel libautotrace3 libMagick-devel
> > > libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5
> > > libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6
> > > libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5
> > > libwraster6 mate-common perl-Image-Magick psiconv pstoedit
> > > pstoedit-devel WindowMaker xfce4-dev-tools xhtml2ps xmlto zbar )
> > >
> > > of course as there are multiples  "depends2:" only the current one
> > > should be used.
> > >
> >
> > Hello, Marco.
> > Sorry for the delay in response.
> > If it is to completely ignore the "requires:" field, the result is the very same:
> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
> > $ ./cygcheck-dep -V
> > cygcheck-dep, version 3.1  # <--- modified testing version
> > $ ./cygcheck-dep -q -S -N libMagickCore6_6
> >  libMagickCore6_6: is recursively needed for ( autotrace dmtx-utils inkscape karbon libautotrace-devel libautotrace3 libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5 libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6 libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5 libwraster6 psiconv pstoedit pstoedit-devel WindowMaker zbar )
> >
> > $ cygcheck-dep -V
> > cygcheck-dep, version 3.0  # <--- current version
> > $ cygcheck-dep -q -S -N libMagickCore6_6
> >  libMagickCore6_6: is recursively needed for ( autotrace dmtx-utils inkscape karbon libautotrace-devel libautotrace3 libMagickC++6_6 libMagickC++6_8 libMagickCore6_2 libMagickCore6_5 libMagickCore6_6 libMagickWand6_2 libMagickWand6_5 libMagickWand6_6 libpstoedit0 libWINGs-devel libWINGs3 libwraster-devel libwraster5 libwraster6 psiconv pstoedit pstoedit-devel WindowMaker zbar )
> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
> >
>
> Are you considering that there is a depends2 field for every version
> and you need to consider only
> the actual one ?
 
What do you mean by the "actual version"?
Setup.ini states that libMagickCore6_6 and libMagickCore6_5 are distinct separate packages, and
the current actual version of libMagickCore6_6 is 6.9.10.11-4 and previous ones are 6.9.10.11-2 and 6.9.10.11-1, and
the current actual version of libMagickCore6_5 is 6.9.9.11-3 and previous one is 6.9.9.11-1.
I am interpreting it this way, or is it not correct?


--