calm: removing test packages override.hint files

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

calm: removing test packages override.hint files

marco atzeri-4
Jon,
It seems calm do not like I remove the test packages and
the override.hint files at the same time

I do not see anything obvious wrong on my instructions

./x86_64/release/GraphicsMagick/-GraphicsMagick-1.3.26-2-src.tar.xz
./x86_64/release/GraphicsMagick/-GraphicsMagick-1.3.26-2.hint
./x86_64/release/GraphicsMagick/-GraphicsMagick-1.3.26-2.tar.xz
./x86_64/release/GraphicsMagick/-override.hint
...


-------- Forwarded Message --------
Subject: calm: cygwin package upload report from sourceware.org for
Marco Atzeri
Date: Tue, 03 Oct 2017 11:25:11 -0000
From: [hidden email]
To: marco.atzeri  gmail.com

ERROR: package 'GraphicsMagick' stability 'test' selects non-existent
version '1.3.26-2'
ERROR: package 'GraphicsMagick-debuginfo' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'ImageMagick' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'ImageMagick-debuginfo' stability 'test' selects
non-existent version '6.9.9.11-2'
ERROR: package 'ImageMagick-doc' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'gdal' stability 'test' selects non-existent version
'2.2.2-2'
ERROR: package 'gdal-debuginfo' stability 'test' selects non-existent
version '2.2.2-2'
ERROR: package 'irssi' stability 'test' selects non-existent version
'1.0.4-2'
ERROR: package 'irssi-debuginfo' stability 'test' selects non-existent
version '1.0.4-2'
ERROR: package 'irssi-devel' stability 'test' selects non-existent
version '1.0.4-2'
ERROR: package 'libGraphicsMagick++12' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'libGraphicsMagick-devel' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'libGraphicsMagick3' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'libGraphicsMagickWand2' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'libMagick-devel' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'libMagickC++6_8' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'libMagickCore6_5' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'libMagickWand6_5' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'libgdal-devel' stability 'test' selects non-existent
version '2.2.2-2'
ERROR: package 'libgdal20' stability 'test' selects non-existent version
'2.2.2-2'
ERROR: package 'perl-Graphics-Magick' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'perl-Image-Magick' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'perl-gdal' stability 'test' selects non-existent version
'2.2.2-2'
ERROR: package 'python-gdal' stability 'test' selects non-existent
version '2.2.2-2'
ERROR: error while validating merged x86 packages for Marco Atzeri
ERROR: package 'GraphicsMagick' stability 'test' selects non-existent
version '1.3.26-2'
ERROR: package 'GraphicsMagick-debuginfo' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'ImageMagick' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'ImageMagick-debuginfo' stability 'test' selects
non-existent version '6.9.9.11-2'
ERROR: package 'ImageMagick-doc' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'gdal' stability 'test' selects non-existent version
'2.2.2-2'
ERROR: package 'gdal-debuginfo' stability 'test' selects non-existent
version '2.2.2-2'
ERROR: package 'irssi' stability 'test' selects non-existent version
'1.0.4-2'
ERROR: package 'irssi-debuginfo' stability 'test' selects non-existent
version '1.0.4-2'
ERROR: package 'irssi-devel' stability 'test' selects non-existent
version '1.0.4-2'
ERROR: package 'libGraphicsMagick++12' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'libGraphicsMagick-devel' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'libGraphicsMagick3' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'libGraphicsMagickWand2' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'libMagick-devel' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'libMagickC++6_8' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'libMagickCore6_5' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'libMagickWand6_5' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'libgdal-devel' stability 'test' selects non-existent
version '2.2.2-2'
ERROR: package 'libgdal20' stability 'test' selects non-existent version
'2.2.2-2'
ERROR: package 'perl-Graphics-Magick' stability 'test' selects
non-existent version '1.3.26-2'
ERROR: package 'perl-Image-Magick' stability 'test' selects non-existent
version '6.9.9.11-2'
ERROR: package 'perl-gdal' stability 'test' selects non-existent version
'2.2.2-2'
ERROR: package 'python-gdal' stability 'test' selects non-existent
version '2.2.2-2'
ERROR: error while validating merged x86_64 packages for Marco Atzeri
SUMMARY: 50 ERROR(s)
Reply | Threaded
Open this post in threaded view
|

Re: calm: removing test packages override.hint files

Jon TURNEY
On 03/10/2017 13:19, Marco Atzeri wrote:

> Jon,
> It seems calm do not like I remove the test packages and
> the override.hint files at the same time
>
> I do not see anything obvious wrong on my instructions
>
> ./x86_64/release/GraphicsMagick/-GraphicsMagick-1.3.26-2-src.tar.xz
> ./x86_64/release/GraphicsMagick/-GraphicsMagick-1.3.26-2.hint
> ./x86_64/release/GraphicsMagick/-GraphicsMagick-1.3.26-2.tar.xz
> ./x86_64/release/GraphicsMagick/-override.hint
> ...

Thanks for pointing this out.

Yeah, this doesn't seem to work as intended.

I suspect you could work around this (for the moment) by uploading an
override.hint with the test: line removed, rather than removing the
override.hint.  You should then be able to remove the override.hint in a
subsequent upload.

Really, I want to move to using test: labels in the pvr.hint to avoid
all these edge cases, but we're not there yet...
Reply | Threaded
Open this post in threaded view
|

Re: calm: removing test packages override.hint files

marco atzeri-4
On 03/10/2017 18:23, Jon Turney wrote:
> On 03/10/2017 13:19, Marco Atzeri wrote:
>> Jon,

>
> I suspect you could work around this (for the moment) by uploading an
> override.hint with the test: line removed, rather than removing the
> override.hint.  You should then be able to remove the override.hint in a
> subsequent upload.

calm has not complained this time


> Really, I want to move to using test: labels in the pvr.hint to avoid
> all these edge cases, but we're not there yet...

no problem. It is a border case anyway.

thanks
Marco