calm error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

calm error

Ken Brown-6
I just uploaded freeglut-3.2.1-1 on both x86 and x86_64.  The upload went fine
on x86_64, but on x86 I get the following:

ERROR: package 'freeglut' version '2.6.0-1' is missing source
ERROR: x86 package set has errors after removing stale packages

Any idea what the problem is?  I do see freeglut-2.6.0-1-src.tar.bz2 on the ftp
server.

Thanks.

Ken
Reply | Threaded
Open this post in threaded view
|

Re: calm error

Jon TURNEY
On 07/10/2019 13:58, Ken Brown wrote:
> I just uploaded freeglut-3.2.1-1 on both x86 and x86_64.  The upload went fine
> on x86_64, but on x86 I get the following:
>
> ERROR: package 'freeglut' version '2.6.0-1' is missing source
> ERROR: x86 package set has errors after removing stale packages
>
> Any idea what the problem is?  I do see freeglut-2.6.0-1-src.tar.bz2 on the ftp
> server.

Thanks.

Sorry the error message isn't very clear, but calm is getting stuck
because it's has an inconsistency where it's thinks it should remove the
2.6.0-1 source, but not the 2.6.0-1 install package

(there's an inconsistency because 2.6.0-1 has different packaging, with
a non-empty freeglut-2.6.0-1.tar.bz2 containing the files which are now
in freeglut-doc; that package is empty in 2.8.1-1, and absent in 3.0.0-1
and later, so "keep n versions" gives different results for source and
install packages)

I manually vaulted that version, and set the upload to be retried, which
seems to have succeeded.