Updated: setup (2.898)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Updated: setup (2.898)

Jon TURNEY

A new version of Setup (2.898) has been uploaded to:

   https://cygwin.com/setup-x86_64.exe  (64 bit version)
   https://cygwin.com/setup-x86.exe     (32 bit version)

Changes compared to 2.897:

- '--upgrade-also' will now also upgrade an obsolete package specified
on command line

(e.g.: setup -q -g -P python3-lxml currently gets you an (empty,
obsolete) python3-lxml package, which is replaced by python36-lxml
(which obsoletes it) the next time setup is run.  After this change,
python36-lxml is installed instead)

(See also the discussion at
https://cygwin.com/ml/cygwin-apps/2017-10/msg00092.html et seq. (where I
come to the (incorrect) conclusion that since we don't need this for
interactive use, it's not needed)

- Remove the 'Bin?' column

The only use this column now has is that unticking it is the same as
selecting the 'uninstall' action.

- Packages can now depend with a version relation on the pseudo-package
'_windows' (which has the same version as the Windows we are running on)

(This is intended for use with the cygwin package, to prevent updates
being installed on Windows versions which it has dropped support for)


Please send bug reports, as usual, to the public mailing list cygwin AT
cygwin DOT com.