Terminfo files not found?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Terminfo files not found?

Jim Zheng
Hello all,

I seem to be running into an issue with my terminal not being recognized after updating to the latest terminfo (6.1-1.20190727). Setting TERM to anything other than 'xterm' results in loss of terminal control where I am unable to use backspace/delete/text editing commands. For example in tmux (with TERM set to 'tmux-256color') vim reports 'E558: Terminal entry not found in terminfo' and the output of infocmp shows 'infocmp: couldn't open terminfo file /usr/share/terminfo/74/tmux-256color' even through the file exists at that path with read access.

Is anyone else running into this issue? I can revert to the previous version of terminfo and everything will work again, but after this long I'm surprised nobody else has brought this issue up. Alternatively there may be some kind of permissions issue on my end getting obscured by an otherwise noninformative error message.

Some additional information that may be of relevance:

$ stat /usr/share/terminfo/74/tmux-256color
  File: /usr/share/terminfo/74/tmux-256color
  Size: 3225            Blocks: 4          IO Block: 65536  regular file
Device: c6eca3b1h/3337397169d   Inode: 1688849860292816  Links: 1
Access: (0644/-rw-r--r--)  Uid: (197609/     jim)   Gid: (197121/    None)
Access: 2020-01-23 15:21:27.671826400 -0800
Modify: 2019-07-28 09:49:23.000000000 -0700
Change: 2020-01-23 11:30:08.971083200 -0800
 Birth: 2020-01-23 11:30:08.970087200 -0800
$ md5sum /usr/share/terminfo/74/tmux-256color
2d86e10db44e7d5032a13f9c229e0887 */usr/share/terminfo/74/tmux-256color


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: Terminfo files not found?

Hans-Bernhard Bröker
Am 24.01.2020 um 00:31 schrieb Jim Zheng:

> I seem to be running into an issue with my terminal not being
> recognized after updating to the latest terminfo (6.1-1.20190727).
> Setting TERM to anything other than 'xterm' results in loss of
> terminal control where I am unable to use backspace/delete/text
> editing commands.

WJFH

> Is anyone else running into this issue? I can revert to the previous
> version of terminfo and everything will work again, but after this
> long I'm surprised nobody else has brought this issue up.

That's almost guaranteed because it's not been an issue for anybody else.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple