Setup usage of sites requiring proxy credentials

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Setup usage of sites requiring proxy credentials

Jose Isaias Cabrera-2

Greetings!

When I run setup, I get a prompt to enter my proxy credentials, which is pretty handy.  I have other tools that just uses the IE or Firefox proxy entries, but now, I am trying to figure out how cygwin setup creates that credential prompt to see if I am able to use it with another tool.  Anyway has any idea?  Thanks.

josé

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: Setup usage of sites requiring proxy credentials

Jon TURNEY
On 06/03/2020 17:00, Jose Isaias Cabrera wrote:
> When I run setup, I get a prompt to enter my proxy credentials, which
> is pretty handy.  I have other tools that just uses the IE or Firefox
> proxy entries, but now, I am trying to figure out how cygwin setup
> creates that credential prompt to see if I am able to use it with
> another tool.  Anyway has any idea?  Thanks.

I think that dialog is presented when setup gets a
'HTTP 407 Proxy Authentication Required' response.

I think if you are using the 'Use System Proxy Settings' setting in
setup, and the system has the proxy credentials, you shouldn't need to
provide the credentials.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: Setup usage of sites requiring proxy credentials

Jose Isaias Cabrera-2

Jon Turney, on Friday, March 6, 2020 01:55 PM, wrote...

> Cc: Jose Isaias Cabrera <[hidden email]>
>
> On 06/03/2020 17:00, Jose Isaias Cabrera wrote:
> > When I run setup, I get a prompt to enter my proxy credentials, which
> > is pretty handy.  I have other tools that just uses the IE or Firefox
> > proxy entries, but now, I am trying to figure out how cygwin setup
> > creates that credential prompt to see if I am able to use it with
> > another tool.  Anyway has any idea?  Thanks.
>
> I think that dialog is presented when setup gets a
> 'HTTP 407 Proxy Authentication Required' response.
Yeah, that is what I am getting now on another application. But, unlike the wonderful cygwin setup application, it lacks the wisdom to popup a credential form.

> I think if you are using the 'Use System Proxy Settings' setting in
> setup, and the system has the proxy credentials, you shouldn't need to
> provide the credentials.
May be so, but, I am sure that in here, the use system settings is turned off and blocked.  Thanks for the quick response.

josé


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple