Running ssh tectia client in cygwin

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Running ssh tectia client in cygwin

ravi r
I am using cygwin in windows 7. When I connect to a remote ssh tectia
server(version 6.4) through ssh tectia client
sshg3.exe(version 6.3.10), from a cygwin terminal, I can successfully
login and for some reason I cannot see my usual dollar
shell prompt. The remote ssh session spawns a ksh. I have tried
renaming my existing .profile(thinking the problem lies some
where inside) and also tried manually running bash on remote session.
Under no circumstance, does a shell prompt appear. I
can however, successfully execute all commands on the remote session.
The command is echoed back to my local session along with the output.

Running the same sshg3.exe client from a windows 'cmd.exe' shell on
the same desktop, connecting to the same tectia server,
there is no issue in seeing the shell prompt, even from my customized
$HOME/.profile.

After adding -t flag to sshg3, the client 'allocates a tty even if
command is given', I get my shell prompts back.
However, every command I enter in the remote session is echoed twice,
which is annoying. Also, remote session is setting
TERM to vt100 and vi editor commands don't work.

In case anyone is wondering, why would I use sshg3.exe in the first
place, the remote tectia ssh server is kicking out
cygwin's native open ssh client during authentication.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple