Re: unison-gtk2-2.10.2-1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: unison-gtk2-2.10.2-1

Andrew Schulman-3
Hello David.  I'm following up on this to the cygwin list.

David Portabella wrote on 11/10/2005 12:58:24 PM:

> while looking for how to install the graphical version of unison for
cygwin,
> I found your post from Nov 2004:
> http://www.cygwin.com/ml/cygwin-apps/2004-11/msg00004.html
>
> there you suggest to create the "unison-gtk2" for cygwin.
> When I run the www.cygwin.com/setup.exe, I only find the text versions
> of unison.
>
> Could you please tell me how could I install the graphical version?

I'm sorry but I never have packaged unison-gtk2 for Cygwin.  I did try
at first, but ran into a fatal error that seemed to be caused by
lablgtk2, the OCaml interface to GTK2.  I wasn't able to solve it right
away, and since I only use the text interface myself, I've never gotten
back to it.

If you want to try it yourself, I suggest installing lablgtk2,
downloading one of the unison source packages, changing the build script
to use UISTYLE=GTK2, and running the build script.  Then run the app and
see how it goes.  Who knows, it might work.  Let me know, and if we can
get it to work, I'll package it for Cygwin.

Andrew.


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

Reply | Threaded
Open this post in threaded view
|

Re: unison-gtk2-2.10.2-1

Yaakov (Cygwin/X)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

[hidden email] wrote:
> I'm sorry but I never have packaged unison-gtk2 for Cygwin.  I did try
> at first, but ran into a fatal error that seemed to be caused by
> lablgtk2, the OCaml interface to GTK2.  I wasn't able to solve it right
> away, and since I only use the text interface myself, I've never gotten
> back to it.

lablgtk2 doesn't build OOTB on Cygwin, as it assumes that we use a Win32
target instead of X11.

I'm attaching a patch which I used to compile lablgtk2, or if you
prefer, I have packages available at:

ftp://sunsite.dk/projects/cygwinports/release/ocaml/lablgtk2/

As I know nothing about OCaml, I don't know if this will fix the patch,
but perhaps it could be a start to getting this working.


Yaakov
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (Cygwin)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFDc7NCpiWmPGlmQSMRAkuhAKCxM01vhBXejEpd01vjYfg9zhxxyACfSD2M
Hw7BBc8sRBgHz8yIrSQVF1c=
=r2ce
-----END PGP SIGNATURE-----

diff -urN -x .build -x .inst -x .sinst -x configure -x Makefile.in -x 'aclocal.m4*' -x ltmain.sh -x 'config.*' -x depcomp -x install-sh -x missing -x mkinstalldirs -x autom4te.cache lablgtk-2.4.0-orig/src/ml_gdk.c lablgtk-2.4.0/src/ml_gdk.c
--- lablgtk-2.4.0-orig/src/ml_gdk.c 2004-06-15 17:42:30.000000000 -0400
+++ lablgtk-2.4.0/src/ml_gdk.c 2005-06-06 19:43:13.343750000 -0400
@@ -2,7 +2,7 @@
 
 #include <string.h>
 #include <gdk/gdk.h>
-#if defined(_WIN32) || defined(__CYGWIN__)
+#if defined(_WIN32)
 #include <gdk/gdkwin32.h>
 #else
 #include <gdk/gdkx.h>
@@ -222,7 +222,7 @@
 ML_0 (GDK_ROOT_PARENT, Val_GdkWindow)
 ML_1 (gdk_window_get_parent, GdkWindow_val, Val_GdkWindow)
 
-#if defined(_WIN32) || defined(__CYGWIN__)
+#if defined(_WIN32)
 CAMLprim value ml_GDK_WINDOW_XWINDOW(value v)
 {
  ml_raise_gdk ("Not available for Win32");
@@ -420,7 +420,7 @@
 CAMLprim value ml_gdk_property_get (value window, value property,
                            value length, value pdelete)
 {
-#if defined(_WIN32) || defined(__CYGWIN__)
+#if defined(_WIN32)
   return Val_unit; /* not supported */
 #else
     GdkAtom atype;


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/
Reply | Threaded
Open this post in threaded view
|

Re: unison-gtk2-2.10.2-1

Andrew Schulman-4
> > I'm sorry but I never have packaged unison-gtk2 for Cygwin.  I did try
> > at first, but ran into a fatal error that seemed to be caused by
> > lablgtk2, the OCaml interface to GTK2.  I wasn't able to solve it right
> > away, and since I only use the text interface myself, I've never gotten
> > back to it.
>
> lablgtk2 doesn't build OOTB on Cygwin, as it assumes that we use a Win32
> target instead of X11.
>
> I'm attaching a patch which I used to compile lablgtk2, or if you
> prefer, I have packages available at:
>
> ftp://sunsite.dk/projects/cygwinports/release/ocaml/lablgtk2/
>
> As I know nothing about OCaml, I don't know if this will fix the patch,
> but perhaps it could be a start to getting this working.

Yaakov, sorry I didn't get back to you sooner.

As part of my attempt to build unison-gtk2 for Cygwin, I did successfully
build and package lablgtk2 for Cygwin.  It's available through the setup
utility.  So the problem isn't building lablgtk2, but rather an error in
unison-gtk2 that seems to be caused by lablgtk2.  But it's been a while and
I'm afraid I don't remember the details now.


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/