Re: XWin problem (xinit launche twice)

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: XWin problem (xinit launche twice)

Cygwin list mailing list
This is a repost, because sending to group gmane.os.cygwin seemingly did
not get through.


Am 27.03.2020 um 12:39 schrieb Franz Fehringer:

> Dear group,
>
> Since a few weeks i see "hangs" wich X11 clients.
> Upon investigation i find two xinit instances (on each XWin launch) in
> the task manager which seemingly lock out each other.
> If i terminate the "right one" then X11 intialization proceeds (xauth,
> xrdb ...) und X11 starts to behave normally.
> Is it possible to fix this (or what can be wrong on my side if this is
> not a general problem)?
>
> Thx & best regards
>
> Franz Fehringer
>
> Win10 1909 latest and german btw

--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: XWin problem (xinit launche twice)

Cygwin list mailing list
On 17.05.2020 12:15, Franz Fehringer via Cygwin wrote:

> This is a repost, because sending to group gmane.os.cygwin seemingly did
> not get through.
>
>
> Am 27.03.2020 um 12:39 schrieb Franz Fehringer:
>> Dear group,
>>
>> Since a few weeks i see "hangs" wich X11 clients.
>> Upon investigation i find two xinit instances (on each XWin launch) in
>> the task manager which seemingly lock out each other.
>> If i terminate the "right one" then X11 intialization proceeds (xauth,
>> xrdb ...) und X11 starts to behave normally.
>> Is it possible to fix this (or what can be wrong on my side if this is
>> not a general problem)?
>>
>> Thx & best regards
>>
>> Franz Fehringer
>>
>> Win10 1909 latest and german btw
>

Hi Franz,

can you follow guideline and provide the cygcheck.out as attachement ?
> Problem reports:      https://cygwin.com/problems.html

How are you starting Xwin ?
Have you any custom setting ?
(eg a .startxwinrc on your home, or similar)

Regards
Marco


--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: XWin problem (xinit launche twice)

Cygwin list mailing list


Am 17.05.2020 um 12:23 schrieb Marco Atzeri:

> On 17.05.2020 12:15, Franz Fehringer via Cygwin wrote:
>> This is a repost, because sending to group gmane.os.cygwin seemingly did
>> not get through.
>>
>>
>> Am 27.03.2020 um 12:39 schrieb Franz Fehringer:
>>> Dear group,
>>>
>>> Since a few weeks i see "hangs" wich X11 clients.
>>> Upon investigation i find two xinit instances (on each XWin launch) in
>>> the task manager which seemingly lock out each other.
>>> If i terminate the "right one" then X11 intialization proceeds (xauth,
>>> xrdb ...) und X11 starts to behave normally.
>>> Is it possible to fix this (or what can be wrong on my side if this is
>>> not a general problem)?
>>>
>>> Thx & best regards
>>>
>>> Franz Fehringer
>>>
>>> Win10 1909 latest and german btw
>>
>
> Hi Franz,
>
> can you follow guideline and provide the cygcheck.out as attachement ?
>> Problem reports:      https://cygwin.com/problems.html
>
> How are you starting Xwin ?
> Have you any custom setting ?
> (eg a .startxwinrc on your home, or similar)
>
> Regards
> Marco
>
>
Here it is.


--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple

cygcheck.out (214K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: XWin problem (xinit launche twice)

Cygwin list mailing list
On 17.05.2020 13:00, Franz Fehringer via Cygwin wrote:
>
>
> Am 17.05.2020 um 12:23 schrieb Marco Atzeri:
>> On 17.05.2020 12:15, Franz Fehringer via Cygwin wrote:
>>> This is a repost, because sending to group gmane.os.cygwin seemingly did
>>> not get through.
>>>
>>>

>>
>> Hi Franz,
>>
>> can you follow guideline and provide the cygcheck.out as attachement ?
>>> Problem reports:      https://cygwin.com/problems.html
>>
>> How are you starting Xwin ?
>> Have you any custom setting ?
>> (eg a .startxwinrc on your home, or similar)

and about these ?

>>
>> Regards
>> Marco
>>
>>
>
> Here it is.
>

what happens if you run just

    PATH="/usr/bin" startxwin

--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: XWin problem (xinit launche twice)

Cygwin list mailing list
Hi Marco,

With a little delay i made some experiments as suggested by you
(disclaimer: i know that top posting is frowned upon in this group but
here it goes):
PATH=/usr/bin startxwin
-> only one xinit (started from mintty / bash)
startxwin -- -listen tcp -nowgl
-> same (only one)
C:\Programs\Cygwin\bin\run.exe --quote /usr/bin/bash.exe -l -c "cd; exec
/usr/bin/startxwin -- -listen tcp -nowgl"
two xinitS are started (started from cmd)
Tested on my business laptop with Windows 1903 latest and Cygwin latest
No .startxwinrc and no modification of /etc/X11/xinit/startxwinrc
With the cmd / run / quote variant also two xinitS on my private
notebook with Windows 1909 latest and Cygwin latest
But the cmd / run / quote exercise gives only ane xinit on my private
desktop (again Windows 1909 latest and Cygwin latest)?
In fact i start not via cmd but using a desktop icon / link.
The extra arguments are for starting WSL X11 clients.
LC_ALL=de_DE.utf8 (all three)
To be continued

Franz


Am 17.05.2020 um 18:42 schrieb Marco Atzeri via Cygwin:

> On 17.05.2020 13:00, Franz Fehringer via Cygwin wrote:
>>
>>
>> Am 17.05.2020 um 12:23 schrieb Marco Atzeri:
>>> On 17.05.2020 12:15, Franz Fehringer via Cygwin wrote:
>>>> This is a repost, because sending to group gmane.os.cygwin seemingly
>>>> did
>>>> not get through.
>>>>
>>>>
>
>>>
>>> Hi Franz,
>>>
>>> can you follow guideline and provide the cygcheck.out as attachement ?
>>>> Problem reports:      https://cygwin.com/problems.html
>>>
>>> How are you starting Xwin ?
>>> Have you any custom setting ?
>>> (eg a .startxwinrc on your home, or similar)
>
> and about these ?
>
>>>
>>> Regards
>>> Marco
>>>
>>>
>>
>> Here it is.
>>
>
> what happens if you run just
>
>    PATH="/usr/bin" startxwin
>
> --
> Problem reports:      https://cygwin.com/problems.html
> FAQ:                  https://cygwin.com/faq/
> Documentation:        https://cygwin.com/docs.html
> Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple

--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: XWin problem (xinit launche twice)

Cygwin list mailing list
path C:\Tools\Cygwin\usr\bin;%PATH% before the run --quote does not
change anything.

Am 21.05.2020 um 19:50 schrieb Franz Fehringer:

> Hi Marco,
>
> With a little delay i made some experiments as suggested by you
> (disclaimer: i know that top posting is frowned upon in this group but
> here it goes):
> PATH=/usr/bin startxwin
> -> only one xinit (started from mintty / bash)
> startxwin -- -listen tcp -nowgl
> -> same (only one)
> C:\Programs\Cygwin\bin\run.exe --quote /usr/bin/bash.exe -l -c "cd; exec
> /usr/bin/startxwin -- -listen tcp -nowgl"
> two xinitS are started (started from cmd)
> Tested on my business laptop with Windows 1903 latest and Cygwin latest
> No .startxwinrc and no modification of /etc/X11/xinit/startxwinrc
> With the cmd / run / quote variant also two xinitS on my private
> notebook with Windows 1909 latest and Cygwin latest
> But the cmd / run / quote exercise gives only ane xinit on my private
> desktop (again Windows 1909 latest and Cygwin latest)?
> In fact i start not via cmd but using a desktop icon / link.
> The extra arguments are for starting WSL X11 clients.
> LC_ALL=de_DE.utf8 (all three)
> To be continued
>
> Franz
>
>
> Am 17.05.2020 um 18:42 schrieb Marco Atzeri via Cygwin:
>> On 17.05.2020 13:00, Franz Fehringer via Cygwin wrote:
>>>
>>> Am 17.05.2020 um 12:23 schrieb Marco Atzeri:
>>>> On 17.05.2020 12:15, Franz Fehringer via Cygwin wrote:
>>>>> This is a repost, because sending to group gmane.os.cygwin seemingly
>>>>> did
>>>>> not get through.
>>>>>
>>>>>
>>>> Hi Franz,
>>>>
>>>> can you follow guideline and provide the cygcheck.out as attachement ?
>>>>> Problem reports:      https://cygwin.com/problems.html
>>>> How are you starting Xwin ?
>>>> Have you any custom setting ?
>>>> (eg a .startxwinrc on your home, or similar)
>> and about these ?
>>
>>>> Regards
>>>> Marco
>>>>
>>>>
>>> Here it is.
>>>
>> what happens if you run just
>>
>>    PATH="/usr/bin" startxwin
>>
>> --
>> Problem reports:      https://cygwin.com/problems.html
>> FAQ:                  https://cygwin.com/faq/
>> Documentation:        https://cygwin.com/docs.html
>> Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple

--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: XWin problem (xinit launche twice)

Cygwin list mailing list
In reply to this post by Cygwin list mailing list
There is maybe a race (condition) i just managed starting xinit only
once (where it was started twice all the time).

Am 21.05.2020 um 19:50 schrieb Franz Fehringer:

> Hi Marco,
>
> With a little delay i made some experiments as suggested by you
> (disclaimer: i know that top posting is frowned upon in this group but
> here it goes):
> PATH=/usr/bin startxwin
> -> only one xinit (started from mintty / bash)
> startxwin -- -listen tcp -nowgl
> -> same (only one)
> C:\Programs\Cygwin\bin\run.exe --quote /usr/bin/bash.exe -l -c "cd; exec
> /usr/bin/startxwin -- -listen tcp -nowgl"
> two xinitS are started (started from cmd)
> Tested on my business laptop with Windows 1903 latest and Cygwin latest
> No .startxwinrc and no modification of /etc/X11/xinit/startxwinrc
> With the cmd / run / quote variant also two xinitS on my private
> notebook with Windows 1909 latest and Cygwin latest
> But the cmd / run / quote exercise gives only ane xinit on my private
> desktop (again Windows 1909 latest and Cygwin latest)?
> In fact i start not via cmd but using a desktop icon / link.
> The extra arguments are for starting WSL X11 clients.
> LC_ALL=de_DE.utf8 (all three)
> To be continued
>
> Franz
>
>
> Am 17.05.2020 um 18:42 schrieb Marco Atzeri via Cygwin:
>> On 17.05.2020 13:00, Franz Fehringer via Cygwin wrote:
>>>
>>> Am 17.05.2020 um 12:23 schrieb Marco Atzeri:
>>>> On 17.05.2020 12:15, Franz Fehringer via Cygwin wrote:
>>>>> This is a repost, because sending to group gmane.os.cygwin seemingly
>>>>> did
>>>>> not get through.
>>>>>
>>>>>
>>>> Hi Franz,
>>>>
>>>> can you follow guideline and provide the cygcheck.out as attachement ?
>>>>> Problem reports:      https://cygwin.com/problems.html
>>>> How are you starting Xwin ?
>>>> Have you any custom setting ?
>>>> (eg a .startxwinrc on your home, or similar)
>> and about these ?
>>
>>>> Regards
>>>> Marco
>>>>
>>>>
>>> Here it is.
>>>
>> what happens if you run just
>>
>>    PATH="/usr/bin" startxwin
>>
>> --
>> Problem reports:      https://cygwin.com/problems.html
>> FAQ:                  https://cygwin.com/faq/
>> Documentation:        https://cygwin.com/docs.html
>> Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple

--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: XWin problem (xinit launche twice)

Cygwin list mailing list
On 21.05.2020 20:07, Franz Fehringer wrote:
> There is maybe a race (condition) i just managed starting xinit only
> once (where it was started twice all the time).
>

A race it is possible.

Sometimes I see xinit or Xwin stuck and I need to kill X,
while the second time goes fine.

May be in your case the first is stuck and a second istance is
risen again.


Running starxwin from mintty is more likely to work for me
the first time. I assume the AV is causing a delay in loading
the libraries and the second repetition takes less time and avoid the
race.

Regards
Marco
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: XWin problem (xinit launche twice)

Cygwin list mailing list
Am 21.05.2020 um 21:38 schrieb Marco Atzeri via Cygwin:

> On 21.05.2020 20:07, Franz Fehringer wrote:
>> There is maybe a race (condition) i just managed starting xinit only
>> once (where it was started twice all the time).
>>
>
> A race it is possible.
>
> Sometimes I see xinit or Xwin stuck and I need to kill X,
> while the second time goes fine.
>
> May be in your case the first is stuck and a second istance is
> risen again.
>
>
> Running starxwin from mintty is more likely to work for me
> the first time. I assume the AV is causing a delay in loading
> the libraries and the second repetition takes less time and avoid the
> race.
>
> Regards
> Marco

Hi Marco,

Thx again for your advice and effort.
There seemingly is not much i can do.
What mechanism would start a second xinit instance?
I start clean (no xinit / XWin around) and have two xinitS in the next
second already.

Best regards

Franz
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple