Re: Emacs (and xterm) crashing

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Emacs (and xterm) crashing

Neil McCurdy
Hi Robert --

I've always had the same problem.  I assumed that it was my
installation of cygwin and that if I wiped it clean all would be well.
 Glad I read your post before I wasted time doing that.  Dired is the
main culprit for me, too.  I frequently have trouble with M-x grep,
though, too.  Never noticed a problem with xterms, but I don't use
them much.

I get the same error message: "X protocol error: BadIDChoice (invalid
resource ID chosen for this connection) on protocol request 1"

I'd love to get this fixed.  I'm afraid I don't have anytime to look
into it at the moment, but I'm happy to beta test.

 Neil



> Hi,
>
>  I have the same problem that was reported by Zdzislaw Meglicki in June
>  and July: emacs sometimes just crashes. I get the message:
>
>  "X protocol error: BadIDChoice (invalid resource ID chosen for this
>  connection) on protocol request 1"
>
>  Mostly this happens when I try to start dired on a directory. This
>  happens both on my machine at work (Windows XP) and my machine at home
>  (Windows 2000). I installed cygwin on my home machine yesterday for
>  the first time in this installation of Windows, and I'm getting the
>  same crashes as I get at work.
>
>  Actually this also happens when I click on an xterm window to get
>  focus sometimes.
>
>  Any clues? Do others also experience this?
>
>  -Robert

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Reply | Threaded
Open this post in threaded view
|

Re: Emacs (and xterm) crashing

Robert Folland
Hi Neil,

Thanks for confirming the problem. I still get the same behaviour, but
it is mostly shortly after starting up. After a while things seem
pretty stable for me. I usually start up two emacs-screens frmo my
.xinitrc, and very often one of them crashes as soon as I start using
it with dired. But after starting that one window interactively I can
have both working fine for the rest of the day.

So it is not a very big problem, mostly annoying around startup (and
very occasionally at other times, not every day).

-Robert

On 11/3/05, Neil McCurdy <[hidden email]> wrote:

> Hi Robert --
>
> I've always had the same problem.  I assumed that it was my installation of
> cygwin and that if I wiped it clean all would be well.  Glad I read your
> post before I wasted time doing that.  Dired is the main culprit for me,
> too.  I frequently have trouble with M-x grep, though, too.  Never noticed a
> problem with xterms, but I don't use them much.
>
> I get the same error message: "X protocol error: BadIDChoice (invalid
> resource ID chosen for this connection) on protocol request 1"
>
> I'd love to get this fixed.  I'm afraid I don't have anytime to look into it
> at the moment, but I'm happy to beta test.
>
> Neil
>
>
> > Hi,
> >
> > I have the same problem that was reported by Zdzislaw Meglicki in June
> > and July: emacs sometimes just crashes. I get the message:
> >
> > "X protocol error: BadIDChoice (invalid resource ID chosen for this
> > connection) on protocol request 1"
> >
> > Mostly this happens when I try to start dired on a directory. This
> > happens both on my machine at work (Windows XP) and my machine at home
> > (Windows 2000). I installed cygwin on my home machine yesterday for
> > the first time in this installation of Windows, and I'm getting the
> > same crashes as I get at work.
> >
> > Actually this also happens when I click on an xterm window to get
> > focus sometimes.
> >
> > Any clues? Do others also experience this?
> >
> > -Robert
>

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/