Re: Cygwin python & multiple versions

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Cygwin python & multiple versions

Jason Tishler
John,

See the following:

    http://cygwin.com/acronyms#PPIOSPE

On Mon, Nov 07, 2005 at 01:09:52PM -0500, John Ehresman wrote:
> Is it possible to install cygwin python 2.4 while retaining cygwin
> python 2.2 & 2.3?  I realize that only one will be available as
> 'python', but things are set up to use python2.2, python2.3, etc
> commands.

I think it is possible if you install the packages manually (without
using setup.exe).  AFAICT, only the following files will overwrite each
other:

    $ tar -tjf python-2.4.1-1.tar.bz2 | egrep -v '2.4|/$'
    usr/bin/idle
    usr/bin/pydoc
    usr/bin/python.exe
    usr/bin/smtpd.py
    usr/share/man/man1/python.1

Jason

--
PGP/GPG Key: http://www.tishler.net/jason/pubkey.asc or key servers
Fingerprint: 7A73 1405 7F2B E669 C19D  8784 1AFD E4CC ECF4 8EF6

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

Reply | Threaded
Open this post in threaded view
|

Re: Cygwin python & multiple versions

Reini Urban
2005/11/9, Jason Tishler <[hidden email]>:

> On Mon, Nov 07, 2005 at 01:09:52PM -0500, John Ehresman wrote:
> > Is it possible to install cygwin python 2.4 while retaining cygwin
> > python 2.2 & 2.3?  I realize that only one will be available as
> > 'python', but things are set up to use python2.2, python2.3, etc
> > commands.
>
> I think it is possible if you install the packages manually (without
> using setup.exe).  AFAICT, only the following files will overwrite each
> other:
>
>     $ tar -tjf python-2.4.1-1.tar.bz2 | egrep -v '2.4|/$'
>     usr/bin/idle
>     usr/bin/pydoc
>     usr/bin/python.exe
>     usr/bin/smtpd.py
>     usr/share/man/man1/python.1

A perfect job for alternatives, with -slave
I do this for libtool.
--
Reini Urban

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

Reply | Threaded
Open this post in threaded view
|

Re: Cygwin python & multiple versions

John Ehresman-2
In reply to this post by Jason Tishler
Jason Tishler wrote:
>>Is it possible to install cygwin python 2.4 while retaining cygwin
>>python 2.2 & 2.3?
>
> I think it is possible if you install the packages manually (without
> using setup.exe).  AFAICT, only the following files will overwrite each
> other:

Thanks.  Manually unpacking the 2.4 package worked, though I also needed
an updated cygwin package.

John

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/