Quick query about Windows versions

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Quick query about Windows versions

cygwin-apps mailing list
Hi all,

Just thought I should ask: is there a perferred version of Windows to
build packages on, or does it not matter?

I currently build on Windows 7, following the tradition of building on
the oldest supported platform, but I have no idea if this is needed with
Cygwin.

Hamish


0x87B761FE07F548D6.asc (3K) Download Attachment
signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Quick query about Windows versions

Achim Gratz
Hamish McIntyre-Bhatty via Cygwin-apps writes:
> Just thought I should ask: is there a perferred version of Windows to
> build packages on, or does it not matter?

Whatever supported version of Windows you use, I'd say.

> I currently build on Windows 7, following the tradition of building on
> the oldest supported platform, but I have no idea if this is needed with
> Cygwin.

No Windows 7 system should still have the ability to connect to the
internet… so no, I don't think you should even try to build there.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Wavetables for the Waldorf Blofeld:
http://Synth.Stromeko.net/Downloads.html#BlofeldUserWavetables
Reply | Threaded
Open this post in threaded view
|

Re: Quick query about Windows versions

cygwin-apps mailing list
On 31/03/2020 17:24, ASSI wrote:

> Hamish McIntyre-Bhatty via Cygwin-apps writes:
>> Just thought I should ask: is there a perferred version of Windows to
>> build packages on, or does it not matter?
> Whatever supported version of Windows you use, I'd say.
>
>> I currently build on Windows 7, following the tradition of building on
>> the oldest supported platform, but I have no idea if this is needed with
>> Cygwin.
> No Windows 7 system should still have the ability to connect to the
> internet… so no, I don't think you should even try to build there.
>
>
> Regards,
> Achim.
Yep, that's why I asked. I'll upgrade the VM to Windows 10 then, if it
makes no difference to Cygwin.

Hamish

0x87B761FE07F548D6.asc (3K) Download Attachment
signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Quick query about Windows versions

Corinna Vinschen-2
On Mar 31 18:58, Hamish McIntyre-Bhatty via Cygwin-apps wrote:

> On 31/03/2020 17:24, ASSI wrote:
> > Hamish McIntyre-Bhatty via Cygwin-apps writes:
> >> Just thought I should ask: is there a perferred version of Windows to
> >> build packages on, or does it not matter?
> > Whatever supported version of Windows you use, I'd say.
> >
> >> I currently build on Windows 7, following the tradition of building on
> >> the oldest supported platform, but I have no idea if this is needed with
> >> Cygwin.
> > No Windows 7 system should still have the ability to connect to the
> > internet… so no, I don't think you should even try to build there.
> >
> >
> > Regards,
> > Achim.
>
> Yep, that's why I asked. I'll upgrade the VM to Windows 10 then, if it
> makes no difference to Cygwin.
None at all.  Right now we still support all versions since Windows
Vista, so any breakage building stuff on these systems is the fault
of the Cygwin core.  Other than that, Achim is right, of course :)


Corinna

--
Corinna Vinschen
Cygwin Maintainer

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Quick query about Windows versions

Thomas Wolff
Am 01.04.2020 um 11:36 schrieb Corinna Vinschen:

> On Mar 31 18:58, Hamish McIntyre-Bhatty via Cygwin-apps wrote:
>> On 31/03/2020 17:24, ASSI wrote:
>>> Hamish McIntyre-Bhatty via Cygwin-apps writes:
>>>> Just thought I should ask: is there a perferred version of Windows to
>>>> build packages on, or does it not matter?
>>> Whatever supported version of Windows you use, I'd say.
>>>
>>>> I currently build on Windows 7, following the tradition of building on
>>>> the oldest supported platform, but I have no idea if this is needed with
>>>> Cygwin.
>>> No Windows 7 system should still have the ability to connect to the
>>> internet… so no, I don't think you should even try to build there.
>>>
>>>
>>> Regards,
>>> Achim.
>> Yep, that's why I asked. I'll upgrade the VM to Windows 10 then, if it
>> makes no difference to Cygwin.
> None at all.  Right now we still support all versions since Windows
> Vista, so any breakage building stuff on these systems is the fault
> of the Cygwin core.  Other than that, Achim is right, of course :)
Unless your package would use w32api and explicitly detect the build
system version to include more or less features depending on it...
Reply | Threaded
Open this post in threaded view
|

Re: Quick query about Windows versions

cygwin-apps mailing list
In reply to this post by Corinna Vinschen-2
On 01/04/2020 10:36, Corinna Vinschen wrote:
> None at all.  Right now we still support all versions since Windows
> Vista, so any breakage building stuff on these systems is the fault
> of the Cygwin core.  Other than that, Achim is right, of course :)
>
>
> Corinna

I'm now all upgraded.

I didn't know Vista was still supported - couldn't get Cygwin to install
on it back in September so I assumed it had been dropped. I can't
remember what the problem was, but perhaps it was my mistake then.

Hamish


0x87B761FE07F548D6.asc (3K) Download Attachment
signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Quick query about Windows versions

Corinna Vinschen-2
In reply to this post by Thomas Wolff
On Apr  1 14:14, Thomas Wolff wrote:

> Am 01.04.2020 um 11:36 schrieb Corinna Vinschen:
> > On Mar 31 18:58, Hamish McIntyre-Bhatty via Cygwin-apps wrote:
> > > On 31/03/2020 17:24, ASSI wrote:
> > > > Hamish McIntyre-Bhatty via Cygwin-apps writes:
> > > > > Just thought I should ask: is there a perferred version of Windows to
> > > > > build packages on, or does it not matter?
> > > > Whatever supported version of Windows you use, I'd say.
> > > >
> > > > > I currently build on Windows 7, following the tradition of building on
> > > > > the oldest supported platform, but I have no idea if this is needed with
> > > > > Cygwin.
> > > > No Windows 7 system should still have the ability to connect to the
> > > > internet… so no, I don't think you should even try to build there.
> > > >
> > > >
> > > > Regards,
> > > > Achim.
> > > Yep, that's why I asked. I'll upgrade the VM to Windows 10 then, if it
> > > makes no difference to Cygwin.
> > None at all.  Right now we still support all versions since Windows
> > Vista, so any breakage building stuff on these systems is the fault
> > of the Cygwin core.  Other than that, Achim is right, of course :)
> Unless your package would use w32api and explicitly detect the build system
> version to include more or less features depending on it...
You have a point there.


Corinna

--
Corinna Vinschen
Cygwin Maintainer

signature.asc (849 bytes) Download Attachment