Problem with pyhton3 + wx

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem with pyhton3 + wx

massimiliano
Hi all,

my question is related to use of GRASS GIS + cygwin + python3 +wx.
I compiled the latest version of GRASS GIS
https://grass.osgeo.org/grass78/source/grass-7.8.2.tar.gz in cygwin.
The major change with respect to the previous versions (which worked
fine) is the switch from python2 to python3. The code builds OK, but
then I start the GUI I get an "ERROR: wxGUI requires wxPython. No
module named 'wx'" error message. The packages related to wx in my
cygwin installations are the following:

libxw-baseu2.8_0
libxw-baseu3.0_0
libwx_gtk2u2.8-devel
libwx_gtk2u2.8_0
libwx_gtk2u3.0_0
libwx_gtk3u3.0_0
python-wx2.8
python2-wx
python2-wxversion

and GRASS GIS configure requires to specify a wx-config, which I set
up as follows:

/usr/bin/wx-config -> /usr/lib/wx/config/gtk2-unicode-release-2.8

Does anyone have a clue about how (IF) I can get the GUI working? I
guess there is no hope, since no python3-wx is listed in the package
selection tool.


Massi

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple