Please upload: guile-1.8.1-1

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Please upload: guile-1.8.1-1

Jan Nieuwenhuizen-2
Reply | Threaded
Open this post in threaded view
|

Re: Please upload: guile-1.8.1-1

d.henman
Guile depends on the GNU MP library.

Was it updated to gmp-4.2.1?
I built the new gnu mp yesterday.
If  the maintainer would like to update it configure it as follows, then do the:

/configure --disable-static --enable-shared  CPPFLAGS="-DDLL_EXPORT"

   make
   make check
   make install

I then built (not knowing someone was working on it) guile-1.8.1 with
the new gmp and it built successfully.

Darel Henman

On 10/24/06, Jan Nieuwenhuizen <[hidden email]> wrote:
Reply | Threaded
Open this post in threaded view
|

Re: Please upload: guile-1.8.1-1

Jan Nieuwenhuizen-2
djh <[hidden email]> writes:

> Guile depends on the GNU MP library.
>
> Was it updated to gmp-4.2.1?

No, cygwin has still gmp-4.2.1, afaict.

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org
Reply | Threaded
Open this post in threaded view
|

Re: Please upload: guile-1.8.1-1

d.henman
I think you mean the "cygwin has still gmp-4.1.4-2"

This should be o.k.since its dynamically linked, but the newer one
might/should be faster......  though maybe not noticeably...

If I knew how to package things properly I'd offer a complete cygwin
package, but, I don't have any place to expose it to you all.
But, here is how to build the newest release.

#both  --disable-static and --enable-shared are required .. so is -DDDL_EXPORT

        ./configure --disable-static --enable-shared  CPPFLAGS="-DDLL_EXPORT"
        make
        make check
        # All tests passed
        make install

This will create:
 /usr/local/bin/cyggmp-3.dll
 /usr/local/lib/libgmp.dll.a
/usr/local/lib/libgmp.la

# set -prefix=/usr   to stuff the lib into /usr/bin and /usr/lib.

On 10/24/06, Jan Nieuwenhuizen <[hidden email]> wrote:

> djh <[hidden email]> writes:
>
> > Guile depends on the GNU MP library.
> >
> > Was it updated to gmp-4.2.1?
>
> No, cygwin has still gmp-4.2.1, afaict.
>
> Jan.
>
> --
> Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
>

In the meantime I'll read up on package maintenance and maybe adopt
and orphan package.

Regards,
  Darel Henman
Reply | Threaded
Open this post in threaded view
|

Re: Please upload: guile-1.8.1-1

Corinna Vinschen-2
In reply to this post by Jan Nieuwenhuizen-2
On Oct 23 21:18, Jan Nieuwenhuizen wrote:
>
> [packaging fix: without ./]
>
> Please remove the guile 1.7.2-3 packages.

Done.  There are also still 1.6.7-1 and 1.6.7-4.  Can I remove one of
them, too?  What about libguile12abi13 and libguile16?

> http://lilypond.org/cygwin/release/guile/setup.hint
> http://lilypond.org/cygwin/release/guile/guile-1.8.1-1-src.tar.bz2
> http://lilypond.org/cygwin/release/guile/guile-1.8.1-1.tar.bz2
> [...]

Uploaded.


Corinna

--
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat
Reply | Threaded
Open this post in threaded view
|

Re: Please upload: guile-1.8.1-1

Jan Nieuwenhuizen-2
Corinna Vinschen <[hidden email]> writes:

> Done.  There are also still 1.6.7-1 and 1.6.7-4.  Can I remove one of
> them, too?

Yes, please remove the -1 variant.

> What about libguile12abi13 and libguile16?

Please remove.  The libguile12abi13 is not referenced anymore, and
libguile16 was only used by the experimental guile-1.7.2-3.

> Uploaded.

Thanks.
Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org
Reply | Threaded
Open this post in threaded view
|

Re: Please upload: guile-1.8.1-1

Corinna Vinschen-2
On Oct 24 11:28, Jan Nieuwenhuizen wrote:

> Corinna Vinschen <[hidden email]> writes:
>
> > Done.  There are also still 1.6.7-1 and 1.6.7-4.  Can I remove one of
> > them, too?
>
> Yes, please remove the -1 variant.
>
> > What about libguile12abi13 and libguile16?
>
> Please remove.  The libguile12abi13 is not referenced anymore, and
> libguile16 was only used by the experimental guile-1.7.2-3.

Done.


Thanks,
Corinna

--
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat