Please test: postgresql-8.1.4-2 (new layout)

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Please test: postgresql-8.1.4-2 (new layout)

Reini Urban
I fixed some postgresql layout and src building issues,
detected by volker zell and myself.
I've had various duplicate man files and missed some other.
See Subject: "cygport pkgcheck" in the cygwin list.

I'd appreciate external testing esp. from the php and xemacs
maintainers, so that they can fix their setup.hint's to include only the
smaller libpq4.

You can also add "http://xarch.tu-graz.ac.at/publ/cygwin/" to your
mirror site to install the as test marked libpq4-8.1.4-2 and
postgresql-8.1.4-2 packages. [Exp]

I've also created various backwards compatible libpq's:
libpq3-7.4.5
libpq4-8.0.7
libpq4-8.1.4

--
Reini


# create the new postgresql 8.1.4 layout and download it
mkdir libecpg-compat1 \
libecpg-compat2 \
libecpg-devel \
libecpg4 \
libecpg5 \
libpgtypes1 \
libpgtypes2 \
libpq-devel \
libpq3 \
libpq4 \
postgresql-client \
postgresql-contrib \
postgresql-devel \
postgresql-doc \
postgresql-plperl \
postgresql-plpython

url="http://xarch.tu-graz.ac.at/publ/cygwin/release/postgresql"

wget $url/setup.hint
wget $url/$url/postgresql-8.1.4-2-src.tar.bz2
wget $url/$url/postgresql-8.1.4-2.tar.bz2

cd libecpg-compat1
wget $url/libecpg-compat1/libecpg_compat1-7.4.5-1.tar.bz2
wget $url/libecpg-compat1/setup.hint

cd ../libecpg-compat2
wget $url/libecpg-compat2/libecpg-compat2-8.1.4-2.tar.bz2
wget $url/libecpg-compat2/setup.hint

cd ../libecpg-devel
wget $url/libecpg-devel/libecpg-devel-8.1.4-2.tar.bz2
wget $url/libecpg-devel/setup.hint

cd ../libecpg4
wget $url/libecpg4/libecpg4-7.4.5-1.tar.bz2
wget $url/libecpg4/setup.hint

cd ../libecpg5
wget $url/libecpg5/libecpg5-8.1.4-2.tar.bz2
wget $url/libecpg5/setup.hint

cd ../libpgtypes1
wget $url/libpgtypes1/libpgtypes1-7.4.5-1.tar.bz2
wget $url/libpgtypes1/setup.hint

cd ../libpgtypes2
wget $url/libpgtypes2/libpgtypes2-8.1.4-2.tar.bz2
wget $url/libpgtypes2/setup.hint

cd ../libpq-devel
wget $url/libpq-devel/libpq-devel-8.1.4-2.tar.bz2
wget $url/libpq-devel/setup.hint

# external source for 7.4.5
cd ../libpq3
mv ../postgresql-7.4.5-1-src.tar.bz2 ./libpq3-7.4.5-1-src.tar.bz2
wget $url/libpq3/libpq3-7.4.5-1.tar.bz2
wget $url/libpq3/setup.hint

cd ../libpq4
wget $url/libpq4/libpq4-8.0.7-1.tar.bz2
wget $url/libpq4/libpq4-8.1.4-2.tar.bz2
wget $url/libpq4/setup.hint

cd ../postgresql-client
wget $url/postgresql-client/postgresql-client-8.0.7-1.tar.bz2
wget $url/postgresql-client/postgresql-client-8.1.4-2.tar.bz2
wget $url/postgresql-client/setup.hint

cd ../postgresql-contrib
wget $url/postgresql-contrib/postgresql-contrib-8.1.4-2.tar.bz2
wget $url/postgresql-contrib/setup.hint

cd ../postgresql-devel
wget $url/postgresql-devel/postgresql-devel-8.1.4-2.tar.bz2
wget $url/postgresql-devel/setup.hint

cd ../postgresql-doc
wget $url/postgresql-doc/postgresql-doc-8.1.4-2.tar.bz2
wget $url/postgresql-doc/setup.hint

cd ../postgresql-plperl
wget $url/postgresql-plperl/postgresql-plperl-8.1.4-2.tar.bz2
wget $url/postgresql-plperl/setup.hint

cd ../postgresql-plpython
wget $url/postgresql-plpython/postgresql-plpython-8.1.4-2.tar.bz2
wget $url/postgresql-plpython/setup.hint

cd ..
rm postgresql-7.4.5-1.tar.bz2
Reply | Threaded
Open this post in threaded view
|

Re: Please test: postgresql-8.1.4-2 (new layout)

Reini Urban
Reini Urban schrieb:
  > You can also add "http://xarch.tu-graz.ac.at/publ/cygwin/" to your
> mirror site to install the as test marked libpq4-8.1.4-2 and
> postgresql-8.1.4-2 packages. [Exp]

Sorry, just saw that the rsync job didn't finish yet.
Superslow net this night.
I'll shout when it's uploaded.
--
Reini
Reply | Threaded
Open this post in threaded view
|

Re: Please test: postgresql-8.1.4-2 (new layout)

Reini Urban
Reini Urban schrieb:
> Sorry, just saw that the rsync job didn't finish yet.
> Superslow net this night.
> I'll shout when it's uploaded.

Shout...
Sorry for the delay. Some stalled remote rsync job. It's up now.

I fixed some postgresql layout and src building issues,
detected by volker zell and myself.
I've had various duplicate man files and missed some other.
See Subject: "cygport pkgcheck" in the cygwin list.

I'd appreciate external testing esp. from the php and xemacs
maintainers, so that they can fix their setup.hint's to include only the
smaller libpq4.

You can also add "http://xarch.tu-graz.ac.at/publ/cygwin/" to your
mirror site to install the as test marked libpq4-8.1.4-2 and
postgresql-8.1.4-2 packages. [Exp]

I've also created various backwards compatible libpq's:
libpq3-7.4.5
libpq4-8.0.7
libpq4-8.1.4
--
Reini

# create the new postgresql 8.1.4 layout and download it
mkdir libecpg-compat1 \
libecpg-compat2 \
libecpg-devel \
libecpg4 \
libecpg5 \
libpgtypes1 \
libpgtypes2 \
libpq-devel \
libpq3 \
libpq4 \
postgresql-client \
postgresql-contrib \
postgresql-devel \
postgresql-doc \
postgresql-plperl \
postgresql-plpython

url="http://xarch.tu-graz.ac.at/publ/cygwin/release/postgresql"

wget $url/setup.hint
wget $url/$url/postgresql-8.1.4-2-src.tar.bz2
wget $url/$url/postgresql-8.1.4-2.tar.bz2

cd libecpg-compat1
wget $url/libecpg-compat1/libecpg_compat1-7.4.5-1.tar.bz2
wget $url/libecpg-compat1/setup.hint

cd ../libecpg-compat2
wget $url/libecpg-compat2/libecpg-compat2-8.1.4-2.tar.bz2
wget $url/libecpg-compat2/setup.hint

cd ../libecpg-devel
wget $url/libecpg-devel/libecpg-devel-8.1.4-2.tar.bz2
wget $url/libecpg-devel/setup.hint

cd ../libecpg4
wget $url/libecpg4/libecpg4-7.4.5-1.tar.bz2
wget $url/libecpg4/setup.hint

cd ../libecpg5
wget $url/libecpg5/libecpg5-8.1.4-2.tar.bz2
wget $url/libecpg5/setup.hint

cd ../libpgtypes1
wget $url/libpgtypes1/libpgtypes1-7.4.5-1.tar.bz2
wget $url/libpgtypes1/setup.hint

cd ../libpgtypes2
wget $url/libpgtypes2/libpgtypes2-8.1.4-2.tar.bz2
wget $url/libpgtypes2/setup.hint

cd ../libpq-devel
wget $url/libpq-devel/libpq-devel-8.1.4-2.tar.bz2
wget $url/libpq-devel/setup.hint

# external source for 7.4.5
cd ../libpq3
mv ../postgresql-7.4.5-1-src.tar.bz2 ./libpq3-7.4.5-1-src.tar.bz2
wget $url/libpq3/libpq3-7.4.5-1.tar.bz2
wget $url/libpq3/setup.hint

cd ../libpq4
wget $url/libpq4/libpq4-8.0.7-1.tar.bz2
wget $url/libpq4/libpq4-8.1.4-2.tar.bz2
wget $url/libpq4/setup.hint

cd ../postgresql-client
wget $url/postgresql-client/postgresql-client-8.0.7-1.tar.bz2
wget $url/postgresql-client/postgresql-client-8.1.4-2.tar.bz2
wget $url/postgresql-client/setup.hint

cd ../postgresql-contrib
wget $url/postgresql-contrib/postgresql-contrib-8.1.4-2.tar.bz2
wget $url/postgresql-contrib/setup.hint

cd ../postgresql-devel
wget $url/postgresql-devel/postgresql-devel-8.1.4-2.tar.bz2
wget $url/postgresql-devel/setup.hint

cd ../postgresql-doc
wget $url/postgresql-doc/postgresql-doc-8.1.4-2.tar.bz2
wget $url/postgresql-doc/setup.hint

cd ../postgresql-plperl
wget $url/postgresql-plperl/postgresql-plperl-8.1.4-2.tar.bz2
wget $url/postgresql-plperl/setup.hint

cd ../postgresql-plpython
wget $url/postgresql-plpython/postgresql-plpython-8.1.4-2.tar.bz2
wget $url/postgresql-plpython/setup.hint

cd ..
rm postgresql-7.4.5-1.tar.bz2
Reply | Threaded
Open this post in threaded view
|

Please upload: postgresql-8.1.4-2 (exp)

Reini Urban
Reini Urban schrieb:
> I fixed some postgresql layout and src building issues,
> detected by volker zell and myself.
> I've had various duplicate man files and missed some other.
> See Subject: "cygport pkgcheck" in the cygwin list.

See attachment
--
Reini Urban
http://phpwiki.org/  http://murbreak.at/
http://helsinki.at/  http://spacemovie.mur.at/

# create the new postgresql 8.1.4 layout and download it
mkdir libecpg-compat1 \
libecpg-compat2 \
libecpg-devel \
libecpg4 \
libecpg5 \
libpgtypes1 \
libpgtypes2 \
libpq-devel \
libpq3 \
libpq4 \
postgresql-client \
postgresql-contrib \
postgresql-devel \
postgresql-doc \
postgresql-plperl \
postgresql-plpython

url="http://xarch.tu-graz.ac.at/publ/cygwin/release/postgresql"

wget $url/setup.hint
wget $url/$url/postgresql-8.1.4-2-src.tar.bz2
wget $url/$url/postgresql-8.1.4-2.tar.bz2

cd libecpg-compat1
wget $url/libecpg-compat1/libecpg_compat1-7.4.5-1.tar.bz2
wget $url/libecpg-compat1/setup.hint

cd ../libecpg-compat2
wget $url/libecpg-compat2/libecpg-compat2-8.1.4-2.tar.bz2
wget $url/libecpg-compat2/setup.hint

cd ../libecpg-devel
wget $url/libecpg-devel/libecpg-devel-8.1.4-2.tar.bz2
wget $url/libecpg-devel/setup.hint

cd ../libecpg4
wget $url/libecpg4/libecpg4-7.4.5-1.tar.bz2
wget $url/libecpg4/setup.hint

cd ../libecpg5
wget $url/libecpg5/libecpg5-8.1.4-2.tar.bz2
wget $url/libecpg5/setup.hint

cd ../libpgtypes1
wget $url/libpgtypes1/libpgtypes1-7.4.5-1.tar.bz2
wget $url/libpgtypes1/setup.hint

cd ../libpgtypes2
wget $url/libpgtypes2/libpgtypes2-8.1.4-2.tar.bz2
wget $url/libpgtypes2/setup.hint

cd ../libpq-devel
wget $url/libpq-devel/libpq-devel-8.1.4-2.tar.bz2
wget $url/libpq-devel/setup.hint

# external source for 7.4.5
cd ../libpq3
mv ../postgresql-7.4.5-1-src.tar.bz2 ./libpq3-7.4.5-1-src.tar.bz2
wget $url/libpq3/libpq3-7.4.5-1.tar.bz2
wget $url/libpq3/setup.hint

cd ../libpq4
wget $url/libpq4/libpq4-8.0.7-1.tar.bz2
wget $url/libpq4/libpq4-8.1.4-2.tar.bz2
wget $url/libpq4/setup.hint

cd ../postgresql-client
wget $url/postgresql-client/postgresql-client-8.0.7-1.tar.bz2
wget $url/postgresql-client/postgresql-client-8.1.4-2.tar.bz2
wget $url/postgresql-client/setup.hint

cd ../postgresql-contrib
wget $url/postgresql-contrib/postgresql-contrib-8.1.4-2.tar.bz2
wget $url/postgresql-contrib/setup.hint

cd ../postgresql-devel
wget $url/postgresql-devel/postgresql-devel-8.1.4-2.tar.bz2
wget $url/postgresql-devel/setup.hint

cd ../postgresql-doc
wget $url/postgresql-doc/postgresql-doc-8.1.4-2.tar.bz2
wget $url/postgresql-doc/setup.hint

cd ../postgresql-plperl
wget $url/postgresql-plperl/postgresql-plperl-8.1.4-2.tar.bz2
wget $url/postgresql-plperl/setup.hint

cd ../postgresql-plpython
wget $url/postgresql-plpython/postgresql-plpython-8.1.4-2.tar.bz2
wget $url/postgresql-plpython/setup.hint

cd ..
rm postgresql-7.4.5-1.tar.bz2
Reply | Threaded
Open this post in threaded view
|

Please upload: postgresql-8.1.4-2 (exp)

Reini Urban
Reini Urban schrieb:
> Reini Urban schrieb:
>> I fixed some postgresql layout and src building issues,
>> detected by volker zell and myself.
>> I've had various duplicate man files and missed some other.
>> See Subject: "cygport pkgcheck" in the cygwin list.

ping

> See attachment


# create the new postgresql 8.1.4 layout and download it
mkdir libecpg-compat1 \
libecpg-compat2 \
libecpg-devel \
libecpg4 \
libecpg5 \
libpgtypes1 \
libpgtypes2 \
libpq-devel \
libpq3 \
libpq4 \
postgresql-client \
postgresql-contrib \
postgresql-devel \
postgresql-doc \
postgresql-plperl \
postgresql-plpython

url="http://xarch.tu-graz.ac.at/publ/cygwin/release/postgresql"

wget $url/setup.hint
wget $url/$url/postgresql-8.1.4-2-src.tar.bz2
wget $url/$url/postgresql-8.1.4-2.tar.bz2

cd libecpg-compat1
wget $url/libecpg-compat1/libecpg_compat1-7.4.5-1.tar.bz2
wget $url/libecpg-compat1/setup.hint

cd ../libecpg-compat2
wget $url/libecpg-compat2/libecpg-compat2-8.1.4-2.tar.bz2
wget $url/libecpg-compat2/setup.hint

cd ../libecpg-devel
wget $url/libecpg-devel/libecpg-devel-8.1.4-2.tar.bz2
wget $url/libecpg-devel/setup.hint

cd ../libecpg4
wget $url/libecpg4/libecpg4-7.4.5-1.tar.bz2
wget $url/libecpg4/setup.hint

cd ../libecpg5
wget $url/libecpg5/libecpg5-8.1.4-2.tar.bz2
wget $url/libecpg5/setup.hint

cd ../libpgtypes1
wget $url/libpgtypes1/libpgtypes1-7.4.5-1.tar.bz2
wget $url/libpgtypes1/setup.hint

cd ../libpgtypes2
wget $url/libpgtypes2/libpgtypes2-8.1.4-2.tar.bz2
wget $url/libpgtypes2/setup.hint

cd ../libpq-devel
wget $url/libpq-devel/libpq-devel-8.1.4-2.tar.bz2
wget $url/libpq-devel/setup.hint

# external source for 7.4.5
cd ../libpq3
mv ../postgresql-7.4.5-1-src.tar.bz2 ./libpq3-7.4.5-1-src.tar.bz2
wget $url/libpq3/libpq3-7.4.5-1.tar.bz2
wget $url/libpq3/setup.hint

cd ../libpq4
wget $url/libpq4/libpq4-8.0.7-1.tar.bz2
wget $url/libpq4/libpq4-8.1.4-2.tar.bz2
wget $url/libpq4/setup.hint

cd ../postgresql-client
wget $url/postgresql-client/postgresql-client-8.0.7-1.tar.bz2
wget $url/postgresql-client/postgresql-client-8.1.4-2.tar.bz2
wget $url/postgresql-client/setup.hint

cd ../postgresql-contrib
wget $url/postgresql-contrib/postgresql-contrib-8.1.4-2.tar.bz2
wget $url/postgresql-contrib/setup.hint

cd ../postgresql-devel
wget $url/postgresql-devel/postgresql-devel-8.1.4-2.tar.bz2
wget $url/postgresql-devel/setup.hint

cd ../postgresql-doc
wget $url/postgresql-doc/postgresql-doc-8.1.4-2.tar.bz2
wget $url/postgresql-doc/setup.hint

cd ../postgresql-plperl
wget $url/postgresql-plperl/postgresql-plperl-8.1.4-2.tar.bz2
wget $url/postgresql-plperl/setup.hint

cd ../postgresql-plpython
wget $url/postgresql-plpython/postgresql-plpython-8.1.4-2.tar.bz2
wget $url/postgresql-plpython/setup.hint

cd ..
rm postgresql-7.4.5-1.tar.bz2
Reply | Threaded
Open this post in threaded view
|

Re: Please upload: postgresql-8.1.4-2 (exp)

Corinna Vinschen-2
On Jun 29 08:47, Reini Urban wrote:
> Reini Urban schrieb:
> >Reini Urban schrieb:
> >>I fixed some postgresql layout and src building issues,
> >>detected by volker zell and myself.
> >>I've had various duplicate man files and missed some other.
> >>See Subject: "cygport pkgcheck" in the cygwin list.
>
> ping

Pong.  Could you please have another look into your script?  It's
assuming that the whole process of downloading, copying and moving will
take place inside of the existing postgresql directory on sourceware.

This won't be the case because the directory would be in a floating
state for quite some time, given the number of files and their size.
Rather, rephrase it so that the download and creation is done in
another dir and then the stuff is just copied over locally with
cpio or so.

I see a few glitches:

> wget $url/setup.hint
> wget $url/$url/postgresql-8.1.4-2-src.tar.bz2
> wget $url/$url/postgresql-8.1.4-2.tar.bz2

$url/$url?

> # external source for 7.4.5
> cd ../libpq3
> mv ../postgresql-7.4.5-1-src.tar.bz2 ./libpq3-7.4.5-1-src.tar.bz2

This just moves the file and renames it, but the content stays the
same, this way unpacking files into a directory postgresql-7.4.5-1,
while the file is called libpq3-7.4.5-1-...  That's not quite
correct.  The file should be repacked so that the sources get
unpacked into a libpq3-7.4.5-1 directory.

>
> cd ../libpq4
> wget $url/libpq4/libpq4-8.0.7-1.tar.bz2
> wget $url/libpq4/libpq4-8.1.4-2.tar.bz2
> wget $url/libpq4/setup.hint
>
> cd ../postgresql-client
> wget $url/postgresql-client/postgresql-client-8.0.7-1.tar.bz2
> wget $url/postgresql-client/postgresql-client-8.1.4-2.tar.bz2
> wget $url/postgresql-client/setup.hint

Here you're downloading libpq4-8.0.7-1.tar.bz2 and
postgresql-client-8.0.7-1.tar.bz2, but where are the sources?  Assuming
they are in postgresql-8.0.7-1-src.tar.bz2, shouldn't the same rename
and move into libpq4 take place as you did for 7.4.5?  This would also
require to rename the files in the source archive, of course.

> cd ..
> rm postgresql-7.4.5-1.tar.bz2

There are also 8.0.4-1, 8.1.0-1 and 8.1.3-1 on sourceware.  These are
obsolete now, right?

Actually, I'd even like it more if the script would download a complete
new postgresql directory, which I could simply replace the old one with.


Corinna

--
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat
Reply | Threaded
Open this post in threaded view
|

Please upload: postgresql-8.1.4-2 (exp)

Reini Urban
Corinna Vinschen schrieb:

> On Jun 29 08:47, Reini Urban wrote:
>> Reini Urban schrieb:
>>> Reini Urban schrieb:
>>>> I fixed some postgresql layout and src building issues,
>>>> detected by volker zell and myself.
>>>> I've had various duplicate man files and missed some other.
>>>> See Subject: "cygport pkgcheck" in the cygwin list.
>> ping
>
> Pong.  Could you please have another look into your script?  It's
> assuming that the whole process of downloading, copying and moving will
> take place inside of the existing postgresql directory on sourceware.
>
> This won't be the case because the directory would be in a floating
> state for quite some time, given the number of files and their size.
> Rather, rephrase it so that the download and creation is done in
> another dir and then the stuff is just copied over locally with
> cpio or so.
Please download it into some private dir and then copy it over.
I just reworked the $url/$url, put out the mv command and repackaged the
libpq3 and 8.0.7-1 src package.

> I see a few glitches:
>
>> wget $url/setup.hint
>> wget $url/$url/postgresql-8.1.4-2-src.tar.bz2
>> wget $url/$url/postgresql-8.1.4-2.tar.bz2
>
> $url/$url?

fixed.

>> # external source for 7.4.5
>> cd ../libpq3
>> mv ../postgresql-7.4.5-1-src.tar.bz2 ./libpq3-7.4.5-1-src.tar.bz2
>
> This just moves the file and renames it, but the content stays the
> same, this way unpacking files into a directory postgresql-7.4.5-1,
> while the file is called libpq3-7.4.5-1-...  That's not quite
> correct.  The file should be repacked so that the sources get
> unpacked into a libpq3-7.4.5-1 directory.

No external sources will be unpacked into some libxxx-<ver>-<cygrelease>
dir. There's no seperate libpq3 upstream package and I will not
artificially create some.
libpq3 consists of one /usr/bin/pq.dll and is created as sideeffect of
building postgresql-7.4.5-1.
This src package has now an additional cygport script for easier picking
apart the various packages afterwards.

>> cd ../libpq4
>> wget $url/libpq4/libpq4-8.0.7-1.tar.bz2
>> wget $url/libpq4/libpq4-8.1.4-2.tar.bz2
>> wget $url/libpq4/setup.hint
>>
>> cd ../postgresql-client
>> wget $url/postgresql-client/postgresql-client-8.0.7-1.tar.bz2
>> wget $url/postgresql-client/postgresql-client-8.1.4-2.tar.bz2
>> wget $url/postgresql-client/setup.hint
>
> Here you're downloading libpq4-8.0.7-1.tar.bz2 and
> postgresql-client-8.0.7-1.tar.bz2, but where are the sources?  Assuming
> they are in postgresql-8.0.7-1-src.tar.bz2, shouldn't the same rename
> and move into libpq4 take place as you did for 7.4.5?  This would also
> require to rename the files in the source archive, of course.
same as above.
the sources for postgresql-client-8.0.7-1 and libpq4-8.0.7-1 are defined
in the setup.hint, which points to the whole postgresql-8.0.7-1-src package.
unpacking them into some artifical postgresql-client or libpq4 dir is
not right. there's no such client or library src package.
the only problem would be to pick them apart.
this is done in the updated postgresql-8.0.7-1.sh build script.
(needed for the cygpq.dll only)

>> cd ..
>> rm postgresql-7.4.5-1.tar.bz2

this is left out now. you have to do that manually.

> There are also 8.0.4-1, 8.1.0-1 and 8.1.3-1 on sourceware.  These are
> obsolete now, right?

right.

> Actually, I'd even like it more if the script would download a complete
> new postgresql directory, which I could simply replace the old one with.

I rather prefer if you download the new stuff, delete the obsolete stuff
and keep the rest. this keeps the old datestamps, we are talking about
11MB files, and my server performs very poor.
--
Reini

# create the new postgresql 8.1.4 layout in some dir
# and download it
mkdir libecpg-compat1 \
libecpg-compat2 \
libecpg-devel \
libecpg4 \
libecpg5 \
libpgtypes1 \
libpgtypes2 \
libpq-devel \
libpq3 \
libpq4 \
postgresql-client \
postgresql-contrib \
postgresql-devel \
postgresql-doc \
postgresql-plperl \
postgresql-plpython

url="http://xarch.tu-graz.ac.at/publ/cygwin/release/postgresql"

wget $url/setup.hint
wget $url/postgresql-8.1.4-2-src.tar.bz2
wget $url/postgresql-8.1.4-2.tar.bz2

cd libecpg-compat1
wget $url/libecpg-compat1/libecpg_compat1-7.4.5-1.tar.bz2
wget $url/libecpg-compat1/setup.hint

cd ../libecpg-compat2
wget $url/libecpg-compat2/libecpg-compat2-8.1.4-2.tar.bz2
wget $url/libecpg-compat2/setup.hint

cd ../libecpg-devel
wget $url/libecpg-devel/libecpg-devel-8.1.4-2.tar.bz2
wget $url/libecpg-devel/setup.hint

cd ../libecpg4
wget $url/libecpg4/libecpg4-7.4.5-1.tar.bz2
wget $url/libecpg4/setup.hint

cd ../libecpg5
wget $url/libecpg5/libecpg5-8.1.4-2.tar.bz2
wget $url/libecpg5/setup.hint

cd ../libpgtypes1
wget $url/libpgtypes1/libpgtypes1-7.4.5-1.tar.bz2
wget $url/libpgtypes1/setup.hint

cd ../libpgtypes2
wget $url/libpgtypes2/libpgtypes2-8.1.4-2.tar.bz2
wget $url/libpgtypes2/setup.hint

cd ../libpq-devel
wget $url/libpq-devel/libpq-devel-8.1.4-2.tar.bz2
wget $url/libpq-devel/setup.hint

cd ../libpq3
wget $url/libpq3/libpq3-7.4.5-1.tar.bz2
wget $url/libpq3/libpq3-7.4.5-1-src.tar.bz2
wget $url/libpq3/setup.hint

cd ../libpq4
wget $url/libpq4/libpq4-8.0.7-1.tar.bz2
wget $url/libpq4/libpq4-8.1.4-2.tar.bz2
wget $url/libpq4/setup.hint

cd ../postgresql-client
wget $url/postgresql-client/postgresql-client-8.0.7-1.tar.bz2
wget $url/postgresql-client/postgresql-client-8.1.4-2.tar.bz2
wget $url/postgresql-client/setup.hint

cd ../postgresql-contrib
wget $url/postgresql-contrib/postgresql-contrib-8.1.4-2.tar.bz2
wget $url/postgresql-contrib/setup.hint

cd ../postgresql-devel
wget $url/postgresql-devel/postgresql-devel-8.1.4-2.tar.bz2
wget $url/postgresql-devel/setup.hint

cd ../postgresql-doc
wget $url/postgresql-doc/postgresql-doc-8.1.4-2.tar.bz2
wget $url/postgresql-doc/setup.hint

cd ../postgresql-plperl
wget $url/postgresql-plperl/postgresql-plperl-8.1.4-2.tar.bz2
wget $url/postgresql-plperl/setup.hint

cd ../postgresql-plpython
wget $url/postgresql-plpython/postgresql-plpython-8.1.4-2.tar.bz2
wget $url/postgresql-plpython/setup.hint

cd ..

Reply | Threaded
Open this post in threaded view
|

Re: Please upload: postgresql-8.1.4-2 (exp)

Corinna Vinschen-2
On Jul 22 15:20, Reini Urban wrote:
> Corinna Vinschen schrieb:
> >>rm postgresql-7.4.5-1.tar.bz2
>
> this is left out now. you have to do that manually.
>
> >There are also 8.0.4-1, 8.1.0-1 and 8.1.3-1 on sourceware.  These are
> >obsolete now, right?

I've uploaded using your script and removed postgresql-7.4.5-1*,
postgresql-8.0.4-1*, postgresql-8.1.0-1* and postgresql-8.1.3-1*
from the top level dir.  Please inspect the directories on the
mirror next to you soon to see if everything's right.


Corinna

--
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat