Please advice for create a package with no soversion specified

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Please advice for create a package with no soversion specified

cygwin-apps mailing list
I'm trying to create a package for googletest, but no soversion is
specified in the original source.

- https://github.com/google/googletest/issues/3113

What soversion should I set if I want to set my own soversion in
cygwin with no soversion specified?

1. 0 (default for autotools)
    - https://github.com/OpenMandrivaAssociation/gtest/blob/master/googletest-1.8.0-sonames.patch
2. 1.10.0 (software version)
    - https://www.archlinux.org/packages/community/x86_64/gtest/
3. other than the above
    - https://packages.debian.org/bullseye/amd64/libgtest-dev/filelist
(provide static only)
Reply | Threaded
Open this post in threaded view
|

Re: Please advice for create a package with no soversion specified

Brian Inglis

On 2020-11-21 17:17, Daisuke Fujimura wrote:

> I'm trying to create a package for googletest, but no soversion is specified
> in the original source.
> https://github.com/google/googletest/issues/3113
> What soversion should I set if I want to set my own soversion in cygwin with
> no soversion specified?
> 1. 0 (default for autotools)
> https://github.com/OpenMandrivaAssociation/gtest/blob/master/googletest-1.8.0-sonames.patch
> 2. 1.10.0 (software version)
> https://www.archlinux.org/packages/community/x86_64/gtest/
> 3. other than the above
> https://packages.debian.org/bullseye/amd64/libgtest-dev/filelist (provide static only)

https://github.com/google/googletest/releases/

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in binary units and prefixes, physical quantities in SI.]
Reply | Threaded
Open this post in threaded view
|

Re: Please advice for create a package with no soversion specified

Achim Gratz
In reply to this post by cygwin-apps mailing list
Daisuke Fujimura via Cygwin-apps writes:
> I'm trying to create a package for googletest, but no soversion is
> specified in the original source.

If upstream doesn't support it, then you should probably not override it.

> - https://github.com/google/googletest/issues/3113
>
> What soversion should I set if I want to set my own soversion in
> cygwin with no soversion specified?
>
> 1. 0 (default for autotools)
>     - https://github.com/OpenMandrivaAssociation/gtest/blob/master/googletest-1.8.0-sonames.patch
> 2. 1.10.0 (software version)
>     - https://www.archlinux.org/packages/community/x86_64/gtest/
> 3. other than the above
>     - https://packages.debian.org/bullseye/amd64/libgtest-dev/filelist
> (provide static only)

It looks like upstream wants you to use the static library.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Wavetables for the Waldorf Blofeld:
http://Synth.Stromeko.net/Downloads.html#BlofeldUserWavetables