Installing error: cygwin1.dll not found

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing error: cygwin1.dll not found

Kevin Worrell
Hi,

I recently installed cygwin on my Windows XP but when I try to run cygwin I
get an error saying ?This application (bash.exe) has failed to start because
cygwin1.dll was not found.  Re-installing the application may fix this
problem.?

I also got a similar message during the initial installation and it keeps
coming up on attempted re-installations (when I tried re-installing the
default packages).  After checking the FAQs I identified the cygwin1.dll in
the cygwin package and have tried to install it specifically on the Select
Packages setup page by switching the toggle button from ?skip? to
?1.5.18-1.?  When I click next, the setup detects additional dependent
packages that need to be downloaded, but when I continue I get one of the
following two errors:

?Fatal error: uncaught exception
Thread: install
Type: St16invalid_argument
Message: URL Scheme not registered!?

or  ?Can?t open (null) for reading: no such file?

What am I doing wrong?  I also found a similar problem in the mailing list
archives, entitled ?Error while installing cygwin? from Abhinav Varshney,
dated 11/5/05.  Thanks for any help that you can give.

Additional info:
setup.exe version 2.510.2.2
cygwin dll release version 1.5.18-1

_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today - it's FREE!
http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

Reply | Threaded
Open this post in threaded view
|

Re: Installing error: cygwin1.dll not found

Larry Hall (Cygwin)
Kevin Worrell wrote:

> Hi,
>
> I recently installed cygwin on my Windows XP but when I try to run
> cygwin I get an error saying ?This application (bash.exe) has failed to
> start because cygwin1.dll was not found.  Re-installing the application
> may fix this problem.?
>
> I also got a similar message during the initial installation and it
> keeps coming up on attempted re-installations (when I tried
> re-installing the default packages).  After checking the FAQs I
> identified the cygwin1.dll in the cygwin package and have tried to
> install it specifically on the Select Packages setup page by switching
> the toggle button from ?skip? to ?1.5.18-1.?  When I click next, the
> setup detects additional dependent packages that need to be downloaded,
> but when I continue I get one of the following two errors:
>
> ?Fatal error: uncaught exception
> Thread: install
> Type: St16invalid_argument
> Message: URL Scheme not registered!?
>
> or  ?Can?t open (null) for reading: no such file?
>
> What am I doing wrong?  I also found a similar problem in the mailing
> list archives, entitled ?Error while installing cygwin? from Abhinav
> Varshney, dated 11/5/05.  Thanks for any help that you can give.
>
> Additional info:
> setup.exe version 2.510.2.2
> cygwin dll release version 1.5.18-1


How about cygcheck output as requested by:

> Problem reports:       http://cygwin.com/problems.html

As to the 'setup.exe' problem, was there anything "interesting" that showed
up in setup.log or setup.log.full?

--
Larry Hall                              http://www.rfk.com
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
838 Washington Street                   (508) 893-9889 - FAX
Holliston, MA 01746

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

Reply | Threaded
Open this post in threaded view
|

Re: Installing error: cygwin1.dll not found

Igor Peshansky
On Wed, 9 Nov 2005, Larry Hall (Cygwin) wrote:

> Kevin Worrell wrote:
> > Hi,
> >
> > I recently installed cygwin on my Windows XP but when I try to run
> > cygwin I get an error saying "This application (bash.exe) has failed
> > to start because cygwin1.dll was not found.  Re-installing the
> > application may fix this problem."
> >
> > I also got a similar message during the initial installation and it
> > keeps coming up on attempted re-installations (when I tried
> > re-installing the default packages).  After checking the FAQs I
> > identified the cygwin1.dll in the cygwin package and have tried to
> > install it specifically on the Select Packages setup page by switching
> > the toggle button from "skip" to "1.5.18-1."  When I click next, the
> > setup detects additional dependent packages that need to be
> > downloaded, but when I continue I get one of the following two errors:
> >
> > "Fatal error: uncaught exception
> > Thread: install
> > Type: St16invalid_argument
> > Message: URL Scheme not registered!"
> >
> > or  "Can't open (null) for reading: no such file"
> >
> > What am I doing wrong?  I also found a similar problem in the mailing
> > list archives, entitled ?Error while installing cygwin? from Abhinav
> > Varshney, dated 11/5/05.  Thanks for any help that you can give.
> >
> > Additional info:
> > setup.exe version 2.510.2.2
> > cygwin dll release version 1.5.18-1
>
> How about cygcheck output as requested by:
>
> > Problem reports:       http://cygwin.com/problems.html
>
> As to the 'setup.exe' problem, was there anything "interesting" that
> showed up in setup.log or setup.log.full?

For the 'setup.exe' problem, nothing interesting will show up in
setup.log* for the OP's version of setup.  Version 2.513-1-alpha[*] added
some interesting debugging info -- this should also show up in the next
setup snapshot, if and when it is built.
        Igor
[*] <http://cs.nyu.edu/~pechtcha/cygwin/setup-2.513-1-alpha.exe>
--
                                http://cs.nyu.edu/~pechtcha/
      |\      _,,,---,,_ [hidden email]
ZZZzz /,`.-'`'    -.  ;-;;,_ [hidden email]
     |,4-  ) )-,_. ,\ (  `'-' Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

If there's any real truth it's that the entire multidimensional infinity
of the Universe is almost certainly being run by a bunch of maniacs. /DA

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

Reply | Threaded
Open this post in threaded view
|

Re: Installing error: cygwin1.dll not found

Kevin Worrell
In reply to this post by Kevin Worrell
>From: Igor Pechtchanski <[hidden email]>
>Reply-To: [hidden email]
>To: [hidden email]
>CC: Kevin Worrell <[hidden email]>
>Subject: Re: Installing error: cygwin1.dll not found
>Date: Wed, 9 Nov 2005 19:20:55 -0500 (EST)
>
>On Wed, 9 Nov 2005, Larry Hall (Cygwin) wrote:
>
> > Kevin Worrell wrote:
> > > Hi,
> > >
> > > I recently installed cygwin on my Windows XP but when I try to run
> > > cygwin I get an error saying "This application (bash.exe) has failed
> > > to start because cygwin1.dll was not found.  Re-installing the
> > > application may fix this problem."
> > >
> > > I also got a similar message during the initial installation and it
> > > keeps coming up on attempted re-installations (when I tried
> > > re-installing the default packages).  After checking the FAQs I
> > > identified the cygwin1.dll in the cygwin package and have tried to
> > > install it specifically on the Select Packages setup page by switching
> > > the toggle button from "skip" to "1.5.18-1."  When I click next, the
> > > setup detects additional dependent packages that need to be
> > > downloaded, but when I continue I get one of the following two errors:
> > >
> > > "Fatal error: uncaught exception
> > > Thread: install
> > > Type: St16invalid_argument
> > > Message: URL Scheme not registered!"
> > >
> > > or  "Can't open (null) for reading: no such file"
> > >
> > > What am I doing wrong?  I also found a similar problem in the mailing
> > > list archives, entitled ?Error while installing cygwin? from Abhinav
> > > Varshney, dated 11/5/05.  Thanks for any help that you can give.
> > >
> > > Additional info:
> > > setup.exe version 2.510.2.2
> > > cygwin dll release version 1.5.18-1
> >
> > How about cygcheck output as requested by:
> >
> > > Problem reports:       http://cygwin.com/problems.html
> >
> > As to the 'setup.exe' problem, was there anything "interesting" that
> > showed up in setup.log or setup.log.full?
>
>For the 'setup.exe' problem, nothing interesting will show up in
>setup.log* for the OP's version of setup.  Version 2.513-1-alpha[*] added
>some interesting debugging info -- this should also show up in the next
>setup snapshot, if and when it is built.
> Igor
>[*] <http://cs.nyu.edu/~pechtcha/cygwin/setup-2.513-1-alpha.exe>
>--
> http://cs.nyu.edu/~pechtcha/
>       |\      _,,,---,,_ [hidden email]
>ZZZzz /,`.-'`'    -.  ;-;;,_ [hidden email]
>      |,4-  ) )-,_. ,\ (  `'-' Igor Pechtchanski, Ph.D.
>     '---''(_/--'  `-'\_) fL a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!
>
>If there's any real truth it's that the entire multidimensional infinity
>of the Universe is almost certainly being run by a bunch of maniacs. /DA
>
>--
>Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
>Problem reports:       http://cygwin.com/problems.html
>Documentation:         http://cygwin.com/docs.html
>FAQ:                   http://cygwin.com/faq/
>


Yes, the beginning of the setup.log file looks like this:

2005/10/26 19:00:42 Starting cygwin install, version 2.510.2.2
2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or
directory
2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or
directory
2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or
directory
2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or
directory
2005/10/26 19:00:42 Current Directory: C:\Documents and Settings\Kevin
Worrell\Desktop
2005/10/26 19:00:42 Changing gid to Users
2005/10/26 19:00:42 Could not open service McShield for query, start and
stop. McAfee may not be installed, or we don't have access.
2005/10/26 19:02:49 io_stream_cygfile: fopen failed 2 No such file or
directory
2005/10/26 19:02:49 source: network install
2005/10/26 19:03:55 root: C:\cygwin binary system
2005/10/26 19:06:03 io_stream_cygfile: fopen failed 2 No such file or
directory
2005/10/26 19:06:03 Selected local directory: C:\Program Files\Cygwin
2005/10/26 19:06:14 net: Direct
2005/10/26 19:06:28 io_stream_cygfile: fopen failed 2 No such file or
directory
2005/10/26 19:06:28 site: ftp://cygwin.dp.ua/pub/mirrors/cygwin
2005/10/26 19:07:34 io_stream_cygfile: fopen failed 2 No such file or
directory

I'm guessing maybe i need to start over fresh with installation, but i'm not
really sure how to do that... i'm working on the cygcheck...

Kevin

_________________________________________________________________
FREE pop-up blocking with the new MSN Toolbar ? get it now!
http://toolbar.msn.click-url.com/go/onm00200415ave/direct/01/


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

Reply | Threaded
Open this post in threaded view
|

Re: Installing error: cygwin1.dll not found

Igor Peshansky
On Thu, 10 Nov 2005, Kevin Worrell wrote:

> > From: Igor Pechtchanski <[hidden email]>
> > Reply-To: [hidden email]
> > To: [hidden email]
> > CC: Kevin Worrell <[hidden email]>

<http://cygwin.com/acronyms/#PCYMTNQREAIYR>.  Thanks.

> > Subject: Re: Installing error: cygwin1.dll not found
> > Date: Wed, 9 Nov 2005 19:20:55 -0500 (EST)
> >
> > On Wed, 9 Nov 2005, Larry Hall (Cygwin) wrote:
> >
> > > Kevin Worrell wrote:
> > > > Hi,
> > > >
> > > > I recently installed cygwin on my Windows XP but when I try to run
> > > > cygwin I get an error saying "This application (bash.exe) has failed
> > > > to start because cygwin1.dll was not found.  Re-installing the
> > > > application may fix this problem."
> > > >
> > > > I also got a similar message during the initial installation and it
> > > > keeps coming up on attempted re-installations (when I tried
> > > > re-installing the default packages).  After checking the FAQs I
> > > > identified the cygwin1.dll in the cygwin package and have tried to
> > > > install it specifically on the Select Packages setup page by switching
> > > > the toggle button from "skip" to "1.5.18-1."  When I click next, the
> > > > setup detects additional dependent packages that need to be
> > > > downloaded, but when I continue I get one of the following two errors:
> > > >
> > > > "Fatal error: uncaught exception
> > > > Thread: install
> > > > Type: St16invalid_argument
> > > > Message: URL Scheme not registered!"
> > > >
> > > > or  "Can't open (null) for reading: no such file"
> > > >
> > > > What am I doing wrong?  I also found a similar problem in the mailing
> > > > list archives, entitled ?Error while installing cygwin? from Abhinav
> > > > Varshney, dated 11/5/05.  Thanks for any help that you can give.
> > > >
> > > > Additional info:
> > > > setup.exe version 2.510.2.2
> > > > cygwin dll release version 1.5.18-1
> > >
> > > How about cygcheck output as requested by:
> > >
> > > > Problem reports:       http://cygwin.com/problems.html
> > >
> > > As to the 'setup.exe' problem, was there anything "interesting" that
> > > showed up in setup.log or setup.log.full?
> >
> > For the 'setup.exe' problem, nothing interesting will show up in
> > setup.log* for the OP's version of setup.  Version 2.513-1-alpha[*] added
> > some interesting debugging info -- this should also show up in the next
> > setup snapshot, if and when it is built.
> > Igor
> > [*] <http://cs.nyu.edu/~pechtcha/cygwin/setup-2.513-1-alpha.exe>
>
> Yes, the beginning of the setup.log file looks like this:
>
> 2005/10/26 19:00:42 Starting cygwin install, version 2.510.2.2
                                                       ^^^^^^^^^
setup.log is accumulated across all setup runs.  You should move it out of
the way and run the newer setup version I mentioned -- you'll get a new
setup.log.

> 2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or directory
> 2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or directory
> 2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or directory
> 2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or directory

These messages are a result of a missing package database -- the newer
setup doesn't print them.

> 2005/10/26 19:00:42 Current Directory: C:\Documents and Settings\Kevin Worrell\Desktop
> 2005/10/26 19:00:42 Changing gid to Users
> 2005/10/26 19:00:42 Could not open service McShield for query, start and stop. McAfee may not be installed, or we don't have access.
> 2005/10/26 19:02:49 io_stream_cygfile: fopen failed 2 No such file or directory
> 2005/10/26 19:02:49 source: network install
> 2005/10/26 19:03:55 root: C:\cygwin binary system
> 2005/10/26 19:06:03 io_stream_cygfile: fopen failed 2 No such file or directory
> 2005/10/26 19:06:03 Selected local directory: C:\Program Files\Cygwin
> 2005/10/26 19:06:14 net: Direct
> 2005/10/26 19:06:28 io_stream_cygfile: fopen failed 2 No such file or directory
> 2005/10/26 19:06:28 site: ftp://cygwin.dp.ua/pub/mirrors/cygwin

Hmm, why are you installing from Ukraine? :-)

> 2005/10/26 19:07:34 io_stream_cygfile: fopen failed 2 No such file or directory
>
> I'm guessing maybe i need to start over fresh with installation, but i'm
> not really sure how to do that...

Does <http://cygwin.com/faq/faq.setup.html#faq.setup.uninstall-all> help?

> i'm working on the cygcheck...

What are the problems?
        Igor
--
                                http://cs.nyu.edu/~pechtcha/
      |\      _,,,---,,_ [hidden email]
ZZZzz /,`.-'`'    -.  ;-;;,_ [hidden email]
     |,4-  ) )-,_. ,\ (  `'-' Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

If there's any real truth it's that the entire multidimensional infinity
of the Universe is almost certainly being run by a bunch of maniacs. /DA

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

Reply | Threaded
Open this post in threaded view
|

Re: Installing error: cygwin1.dll not found

Kevin Worrell
ok...thanks Igor and Larry...i finally got it installed and running using a
mirror site closer to home.  thank you both greatly for your help.

Kevin


>From: Igor Pechtchanski <[hidden email]>
>Reply-To: [hidden email]
>To: Kevin Worrell <[hidden email]>
>CC: [hidden email]
>Subject: Re: Installing error: cygwin1.dll not found
>Date: Thu, 10 Nov 2005 16:37:29 -0500 (EST)
>
>On Thu, 10 Nov 2005, Kevin Worrell wrote:
>
> > > From: Igor Pechtchanski <[hidden email]>
> > > Reply-To: [hidden email]
> > > To: [hidden email]
> > > CC: Kevin Worrell <[hidden email]>
>
><http://cygwin.com/acronyms/#PCYMTNQREAIYR>.  Thanks.
>
> > > Subject: Re: Installing error: cygwin1.dll not found
> > > Date: Wed, 9 Nov 2005 19:20:55 -0500 (EST)
> > >
> > > On Wed, 9 Nov 2005, Larry Hall (Cygwin) wrote:
> > >
> > > > Kevin Worrell wrote:
> > > > > Hi,
> > > > >
> > > > > I recently installed cygwin on my Windows XP but when I try to run
> > > > > cygwin I get an error saying "This application (bash.exe) has
>failed
> > > > > to start because cygwin1.dll was not found.  Re-installing the
> > > > > application may fix this problem."
> > > > >
> > > > > I also got a similar message during the initial installation and
>it
> > > > > keeps coming up on attempted re-installations (when I tried
> > > > > re-installing the default packages).  After checking the FAQs I
> > > > > identified the cygwin1.dll in the cygwin package and have tried to
> > > > > install it specifically on the Select Packages setup page by
>switching
> > > > > the toggle button from "skip" to "1.5.18-1."  When I click next,
>the
> > > > > setup detects additional dependent packages that need to be
> > > > > downloaded, but when I continue I get one of the following two
>errors:
> > > > >
> > > > > "Fatal error: uncaught exception
> > > > > Thread: install
> > > > > Type: St16invalid_argument
> > > > > Message: URL Scheme not registered!"
> > > > >
> > > > > or  "Can't open (null) for reading: no such file"
> > > > >
> > > > > What am I doing wrong?  I also found a similar problem in the
>mailing
> > > > > list archives, entitled ?Error while installing cygwin? from
>Abhinav
> > > > > Varshney, dated 11/5/05.  Thanks for any help that you can give.
> > > > >
> > > > > Additional info:
> > > > > setup.exe version 2.510.2.2
> > > > > cygwin dll release version 1.5.18-1
> > > >
> > > > How about cygcheck output as requested by:
> > > >
> > > > > Problem reports:       http://cygwin.com/problems.html
> > > >
> > > > As to the 'setup.exe' problem, was there anything "interesting" that
> > > > showed up in setup.log or setup.log.full?
> > >
> > > For the 'setup.exe' problem, nothing interesting will show up in
> > > setup.log* for the OP's version of setup.  Version 2.513-1-alpha[*]
>added
> > > some interesting debugging info -- this should also show up in the
>next
> > > setup snapshot, if and when it is built.
> > > Igor
> > > [*] <http://cs.nyu.edu/~pechtcha/cygwin/setup-2.513-1-alpha.exe>
> >
> > Yes, the beginning of the setup.log file looks like this:
> >
> > 2005/10/26 19:00:42 Starting cygwin install, version 2.510.2.2
>                                                        ^^^^^^^^^
>setup.log is accumulated across all setup runs.  You should move it out of
>the way and run the newer setup version I mentioned -- you'll get a new
>setup.log.
>
> > 2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or
>directory
> > 2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or
>directory
> > 2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or
>directory
> > 2005/10/26 19:00:42 io_stream_cygfile: fopen failed 2 No such file or
>directory
>
>These messages are a result of a missing package database -- the newer
>setup doesn't print them.
>
> > 2005/10/26 19:00:42 Current Directory: C:\Documents and Settings\Kevin
>Worrell\Desktop
> > 2005/10/26 19:00:42 Changing gid to Users
> > 2005/10/26 19:00:42 Could not open service McShield for query, start and
>stop. McAfee may not be installed, or we don't have access.
> > 2005/10/26 19:02:49 io_stream_cygfile: fopen failed 2 No such file or
>directory
> > 2005/10/26 19:02:49 source: network install
> > 2005/10/26 19:03:55 root: C:\cygwin binary system
> > 2005/10/26 19:06:03 io_stream_cygfile: fopen failed 2 No such file or
>directory
> > 2005/10/26 19:06:03 Selected local directory: C:\Program Files\Cygwin
> > 2005/10/26 19:06:14 net: Direct
> > 2005/10/26 19:06:28 io_stream_cygfile: fopen failed 2 No such file or
>directory
> > 2005/10/26 19:06:28 site: ftp://cygwin.dp.ua/pub/mirrors/cygwin
>
>Hmm, why are you installing from Ukraine? :-)
>
> > 2005/10/26 19:07:34 io_stream_cygfile: fopen failed 2 No such file or
>directory
> >
> > I'm guessing maybe i need to start over fresh with installation, but i'm
> > not really sure how to do that...
>
>Does <http://cygwin.com/faq/faq.setup.html#faq.setup.uninstall-all> help?
>
> > i'm working on the cygcheck...
>
>What are the problems?
> Igor
>--
> http://cs.nyu.edu/~pechtcha/
>       |\      _,,,---,,_ [hidden email]
>ZZZzz /,`.-'`'    -.  ;-;;,_ [hidden email]
>      |,4-  ) )-,_. ,\ (  `'-' Igor Pechtchanski, Ph.D.
>     '---''(_/--'  `-'\_) fL a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!
>
>If there's any real truth it's that the entire multidimensional infinity
>of the Universe is almost certainly being run by a bunch of maniacs. /DA

_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today - it's FREE!
http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/