Quantcast

Import error with python2-httplib2-0.9.2-1

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Import error with python2-httplib2-0.9.2-1

Michael Diamond
Hello all,

I’m running into trouble with the python2-httplib2[1] package in a
fresh install of Cygwin:

$ python -c 'import httplib2'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line
95, in <module>
    from iri2uri import iri2uri
  File "/usr/lib/python2.7/site-packages/httplib2/iri2uri.py", line
15, in <module>
    import urllib.parse
ImportError: No module named parse

As noted here[2], urllib.parse was introduced in Python 3, so it seems
odd for a 2.7 file to be expecting it. I also notice that it’s `import
urlparse` on GitHub[3], for whatever that’s worth.

[1]: https://cygwin.com/cgi-bin2/package-cat.cgi?file=x86_64%2Fpython2-httplib2%2Fpython2-httplib2-0.9.2-1
[2]: http://stackoverflow.com/q/29358403/113632
[3]: https://github.com/httplib2/httplib2/blob/master/python2/httplib2/iri2uri.py#L15

Thanks,

Michael

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Loading...