ImageMagick 6 vs 7

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

ImageMagick 6 vs 7

Yaakov Selkowitz
Marco,

A recent discussion on Fedora's devel list has brought to my attention
that ImageMagick 7 would be incompatible with 6 not only wrt API/ABI but
also wrt CLI (affecting scripts etc.).  It would seem prudent to stick
with the 6 series for the time being until the Linux distributions sort
this out.

If you concur, would you mind updating ImageMagick to the latest 6.9
release?  It seems to be somewhat behind at the moment.

--
Yaakov


signature.asc (235 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: ImageMagick 6 vs 7

marco atzeri-4
On 04/09/2017 21:52, Yaakov Selkowitz wrote:

> Marco,
>
> A recent discussion on Fedora's devel list has brought to my attention
> that ImageMagick 7 would be incompatible with 6 not only wrt API/ABI but
> also wrt CLI (affecting scripts etc.).  It would seem prudent to stick
> with the 6 series for the time being until the Linux distributions sort
> this out.
>
> If you concur, would you mind updating ImageMagick to the latest 6.9
> release?  It seems to be somewhat behind at the moment.
>

I was not planning to move to 7.x for the time being.

I will look on latest 6.9 but I had the impression they bumped
the API in anycase.
It is the worst package as stability that I am aware...

Regards
Marco
Reply | Threaded
Open this post in threaded view
|

Re: ImageMagick 6 vs 7

Yaakov Selkowitz
On 2017-09-04 15:03, Marco Atzeri wrote:

> On 04/09/2017 21:52, Yaakov Selkowitz wrote:
>> A recent discussion on Fedora's devel list has brought to my attention
>> that ImageMagick 7 would be incompatible with 6 not only wrt API/ABI but
>> also wrt CLI (affecting scripts etc.).  It would seem prudent to stick
>> with the 6 series for the time being until the Linux distributions sort
>> this out.
>>
>> If you concur, would you mind updating ImageMagick to the latest 6.9
>> release?  It seems to be somewhat behind at the moment.
>
> I was not planning to move to 7.x for the time being.
Probably for the best.

> I will look on latest 6.9 but I had the impression they bumped
> the API in anycase.

Yes, but it sounds like that shouldn't require more than a customary
rebuild of the few packages which use libMagick{Core,Wand}6.

> It is the worst package as stability that I am aware...

It's definitely among the worst.  I do wonder if at least 6 will settle
down ABI-wise with 7 out, but given their history, who knows.

--
Yaakov


signature.asc (235 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: ImageMagick 6 vs 7

marco atzeri-4
On 05/09/2017 00:38, Yaakov Selkowitz wrote:
> On 2017-09-04 15:03, Marco Atzeri wrote:
>> On 04/09/2017 21:52, Yaakov Selkowitz wrote:
>>> A recent discussion on Fedora's devel list has brought to my attention
>>> that ImageMagick 7 would be incompatible with 6 not only wrt API/ABI but
>>> also wrt CLI (affecting scripts etc.).  It would seem prudent to stick
>>> with the 6 series for the time being until the Linux distributions sort
>>> this out.

>> It is the worst package as stability that I am aware...
>
> It's definitely among the worst.  I do wonder if at least 6 will settle
> down ABI-wise with 7 out, but given their history, who knows.
>

uploaded. They changed 3 times API between 6.9.5 and 6.9.9.