[ITP] wxwidgets 3.0.4

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[ITP] wxwidgets 3.0.4

Hamish MB
Hello,

I understand that there is an existing Cygwin package for wxWidgets
3.0.3. However, this is not new enough to build wxPython 4, and hence
support wxPython apps that use Python 3 on Cygwin.

As a result of a desire for this in order to support Windows, I would
like to propose adding wxWidgets 3.0.4 to the Cygwin repositories. I
have successfully created a .cygport file that can build packages for
wxWidgets 3.0.4. I'm unsure what to do next. Do I need to submit a pull
request to "https://github.com/cygwinports/wxWidgets3.0" as well?

Thanks,

Hamish

Reply | Threaded
Open this post in threaded view
|

Re: [ITP] wxwidgets 3.0.4

Yaakov Selkowitz
On Thu, 2019-09-05 at 14:11 +0000, Hamish MB wrote:
> I understand that there is an existing Cygwin package for wxWidgets
> 3.0.3. However, this is not new enough to build wxPython 4, and hence
> support wxPython apps that use Python 3 on Cygwin.

Then you should be asking for an update to the existing wxWidgets3.0
package.  Since 3.0.3 and 3.0.4 cannot be installed in parallel, an ITP
is not appropriate.

--
Yaakov


Reply | Threaded
Open this post in threaded view
|

Re: [ITP] wxwidgets 3.0.4

Hamish MB
On 05/09/2019 15:33, Yaakov Selkowitz wrote:

> On Thu, 2019-09-05 at 14:11 +0000, Hamish MB wrote:
>> I understand that there is an existing Cygwin package for wxWidgets
>> 3.0.3. However, this is not new enough to build wxPython 4, and hence
>> support wxPython apps that use Python 3 on Cygwin.
> Then you should be asking for an update to the existing wxWidgets3.0
> package.  Since 3.0.3 and 3.0.4 cannot be installed in parallel, an ITP
> is not appropriate.
>
> --
> Yaakov

Okay, that makes sense. I have a working cygport file ready in a
repository, so shall I submit a pull request instead then?

My apologies,

Hamish