[ITP] libftdi1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[ITP] libftdi1

Åke Rehnman
Hello!

Any chance to get libftdi1 to be included in cygwin distribution?

libftdi1 is available in most distributions like ubuntu:
http://packages.ubuntu.com/search?keywords=libftdi1

Since I've never submitted a package before I was not sure if I should
include libconfuse in .hint. Although it's not required to be able to
use the libftdi1 lib but to build ftdi_eeprom.exe.

category: Libs
requires: bash cygwin libgcc1 libstdc++6 libusb1.0-devel pkg-config python
sdesc: "FTDI USB driver with bitbang mode"
ldesc: "libFTDI is an open source library to talk to FTDI chips: FT232BM, FT245BM, FT2232C, FT2232D, FT245R, FT232H and FT230X including the popular bitbang mode. The library is linked with your program in userspace, no kernel driver required.
libFTDI works perfectly with Linux, Windows, MacOS X and BSD variants thanks to libusb."

https://stm8-binutils-gdb.sourceforge.io/cygwin/x86/libftdi1/libftdi1-1.3-1.hint
https://stm8-binutils-gdb.sourceforge.io/cygwin/x86/libftdi1/libftdi1-1.3-1-src.tar.xz
https://stm8-binutils-gdb.sourceforge.io/cygwin/x86/libftdi1/libftdi1-1.3-1.tar.xz
https://stm8-binutils-gdb.sourceforge.io/cygwin/x86/libftdi1/libftdi1-debuginfo/libftdi1-debuginfo-1.3-1.hint
https://stm8-binutils-gdb.sourceforge.io/cygwin/x86/libftdi1/libftdi1-debuginfo/libftdi1-debuginfo-1.3-1.tar.xz
https://stm8-binutils-gdb.sourceforge.io/cygwin/x86_64/libftdi1/libftdi1-1.3-1.hint
https://stm8-binutils-gdb.sourceforge.io/cygwin/x86_64/libftdi1/libftdi1-1.3-1.tar.xz
https://stm8-binutils-gdb.sourceforge.io/cygwin/x86_64/libftdi1/libftdi1-1.3-1-src.tar.xz
https://stm8-binutils-gdb.sourceforge.io/cygwin/x86_64/libftdi1/libftdi1-debuginfo/libftdi1-debuginfo-1.3-1.hint
https://stm8-binutils-gdb.sourceforge.io/cygwin/x86_64/libftdi1/libftdi1-debuginfo/libftdi1-debuginfo-1.3-1.tar.xz

/Ake
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[ITP] libftdi1 & libconfuse

Åke Rehnman
Hello all,

One more effort to try getting some attention towards libftdi and
libconfuse packages...

Both libftdi and libconfuse are available in ubuntu and debian + others.
Libftdi is used with openocd among others. Libconfuse is used by eeprom
programmer for libftdi.

libftdi1 is released under LGPL 2.1 and eeprom programmer under GPL 2.
See https://www.intra2net.com/en/developer/libftdi/index.php

libconfuse is released under ISC License. See
https://github.com/martinh/libconfuse/blob/master/LICENSE

Regards

/Ake

Libftdi1:

category: Libs
requires: bash cygwin libconfuse1 libgcc1 libstdc++6 libusb1.0 libconfuse1
sdesc: "Library to control and program the FTDI USB controller"
ldesc: "libFTDI is an open source library to talk to FTDI chips: FT232BM, FT245BM, FT2232C, FT2232D, FT245R, FT232H and FT230X including the popular bitbang mode. The library is linked with your program in userspace, no kernel driver required. libFTDI works perfectly with Linux, Windows, MacOS X and BSD variants thanks to libusb."


Libconfuse:

category: Libs
requires: cygwin libintl8
sdesc: "Library for parsing configuration files"
ldesc: "libConfuse is a configuration file parser library, licensed under the terms of the ISC license, and written in C."


Files available here: https://stm8-binutils-gdb.sourceforge.io/cygwin/

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [ITP] libftdi1 & libconfuse

Jon TURNEY
On 18/04/2017 19:50, Åke Rehnman wrote:
> Hello all,
>
> One more effort to try getting some attention towards libftdi and
> libconfuse packages...

Thank you for your patience and sorry about the delay.

> Both libftdi and libconfuse are available in ubuntu and debian + others.
> Libftdi is used with openocd among others. Libconfuse is used by eeprom
> programmer for libftdi.
>
> libftdi1 is released under LGPL 2.1 and eeprom programmer under GPL 2.
> See https://www.intra2net.com/en/developer/libftdi/index.php
>
> libconfuse is released under ISC License. See
> https://github.com/martinh/libconfuse/blob/master/LICENSE
>
[..]
>
> Files available here: https://stm8-binutils-gdb.sourceforge.io/cygwin/

libftdi1.cygport should use 'DEPEND=pkgconfig(libconfuse)' rather than
hand-rolling a check for it.

I guess that it should also have 'pkgconfig(libusb-1.0) swig'.

With those things fixed, package looks good, so please provide a ssh key
as per https://cygwin.com/package-upload.html

Loading...