[ITA] lua-5.3.6, lua-5.4.2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[ITA] lua-5.3.6, lua-5.4.2

cygwin-apps mailing list
ITA for libnice, which has been maintained by Yaakov [1].

Now, the latest upstream of lua is 5.4.2, and last 5.3-release is 5.3.6 [2].

A new candidate cygport files are placed at [3] for 5.4.2,
and at [4] for 5.3.6.

They build successfully on Cygwin AppVeyor CI
  5.4.2 ID 1706: [5]
  5.3.6 ID 1705: [6]

Generated package files are placed at [7] for 5.4.2, and
at [8] for 5.3.6.

Packaging is rearranged from 5.3.5:
  cyglua-5.3.dll is moved into a new package liblua5.3
  (correspondingly cyglua-5.4.dll is contained in liblua5.4)
  lua-devel is obsoleted by liblua-devel


[1]: https://cygwin.com/git/?p=git/cygwin-packages/lua.git
[2]: https://www.lua.org/versions.html

[3]: https://github.com/cygwin-lem/lua-cygport/tree/n_5.4.2-1
[4]: https://github.com/cygwin-lem/lua-cygport/tree/n_5.3.6-1

[5]: https://cygwin.com/cgi-bin2/jobs.cgi?id=1706
  or https://ci.appveyor.com/project/cygwin/scallywag/builds/37189475
[6]: https://cygwin.com/cgi-bin2/jobs.cgi?id=1705
  or https://ci.appveyor.com/project/cygwin/scallywag/builds/37189473

[7]: https://github.com/cygwin-lem/lua-cygport/tree/n_5.4.2-1_gh-pages
[8]: https://github.com/cygwin-lem/lua-cygport/tree/n_5.3.6-1_gh-pages


Regards,

Lem

Reply | Threaded
Open this post in threaded view
|

Re: [ITA] lua-5.3.6, lua-5.4.2

cygwin-apps mailing list
On 10.01.2021 07:48, Lemures Lemniscati via Cygwin-apps wrote:

> ITA for libnice, which has been maintained by Yaakov [1].
>
> Now, the latest upstream of lua is 5.4.2, and last 5.3-release is 5.3.6 [2].
>
> A new candidate cygport files are placed at [3] for 5.4.2,
> and at [4] for 5.3.6.
>
> They build successfully on Cygwin AppVeyor CI
>    5.4.2 ID 1706: [5]
>    5.3.6 ID 1705: [6]
>
> Generated package files are placed at [7] for 5.4.2, and
> at [8] for 5.3.6.
>
> Packaging is rearranged from 5.3.5:
>    cyglua-5.3.dll is moved into a new package liblua5.3
>    (correspondingly cyglua-5.4.dll is contained in liblua5.4)
>    lua-devel is obsoleted by liblua-devel

GTG

Marco
Reply | Threaded
Open this post in threaded view
|

Re: [ITA] lua-5.3.6, lua-5.4.2

cygwin-apps mailing list
On Sun, 10 Jan 2021 12:41:24 +0100, Marco Atzeri via Cygwin-apps
> On 10.01.2021 07:48, Lemures Lemniscati via Cygwin-apps wrote:
> >
> > Now, the latest upstream of lua is 5.4.2, and last 5.3-release is 5.3.6 [2].
> >
> > A new candidate cygport files are placed at [3] for 5.4.2,
> > and at [4] for 5.3.6.
> >
> GTG
>
Thank you, Marco.

Regards,

Lem