Fwd: calm: cygwin package upload report

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: calm: cygwin package upload report

Brian Inglis
Hi folks,

Any ideas how to fix these complaints about nonexistent packages?
These mingw64 packages do not yet have any DEPENDS/BUILD_REQUIRES but unsure
what if anything to add other than base with cross tools.

> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-autoconf', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-automake', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-libssl', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-openldap', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-autoconf', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-automake', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-libssl', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-openldap', but nothing satisfies that
> ERROR: error while validating merged x86 packages for Brian Inglis
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-autoconf', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-automake', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-libssl', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-openldap', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-autoconf', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-automake', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-libssl', but nothing satisfies that
> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-openldap', but nothing satisfies that
> ERROR: error while validating merged x86_64 packages for Brian Inglis
> SUMMARY: 1 WARNING(s), 18 ERROR(s)

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in IEC units and prefixes, physical quantities in SI.]
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: calm: cygwin package upload report

Jon TURNEY
On 06/09/2020 18:09, Brian Inglis wrote:

> Hi folks,
>
> Any ideas how to fix these complaints about nonexistent packages?
> These mingw64 packages do not yet have any DEPENDS/BUILD_REQUIRES but unsure
> what if anything to add other than base with cross tools.
>
>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-autoconf', but nothing satisfies that
>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-automake', but nothing satisfies that
>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-libssl', but nothing satisfies that
>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires: 'mingw64-x86_64-openldap', but nothing satisfies that
>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-autoconf', but nothing satisfies that
>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-automake', but nothing satisfies that
>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-libssl', but nothing satisfies that
>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends: 'mingw64-x86_64-openldap', but nothing satisfies that

Your uploaded mingw64-x86_64-curl-7.72.0-1.hint contains:

requires: bash mingw64-x86_64-autoconf mingw64-x86_64-automake
mingw64-x86_64-libssh2 mingw64-x86_64-libssl mingw64-x86_64-openldap
pkg-config

so these complaints seems correct.

If these aren't coming from a REQUIRES in your .cygport, but are being
automatically added by cygport, that would seem to be a bug there.

Can you show the .cygport file you are using?
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: calm: cygwin package upload report

Brian Inglis
On 2020-09-07 08:04, Jon Turney wrote:

> On 06/09/2020 18:09, Brian Inglis wrote:
>> Hi folks,
>>
>> Any ideas how to fix these complaints about nonexistent packages?
>> These mingw64 packages do not yet have any DEPENDS/BUILD_REQUIRES but unsure
>> what if anything to add other than base with cross tools.
>>
>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>
> Your uploaded mingw64-x86_64-curl-7.72.0-1.hint contains:
>
> requires: bash mingw64-x86_64-autoconf mingw64-x86_64-automake
> mingw64-x86_64-libssh2 mingw64-x86_64-libssl mingw64-x86_64-openldap pkg-config
>
> so these complaints seems correct.
>
> If these aren't coming from a REQUIRES in your .cygport, but are being
> automatically added by cygport, that would seem to be a bug there.
>
> Can you show the .cygport file you are using?

Don't even look at hints to check normally.

Pushed to:

https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-x86_64-curl.git;a=blob;f=mingw64-x86_64-curl.cygport

https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-i686-curl.git;a=blob;f=mingw64-i686-curl.cygport

minimal changes to version and URLs to https:, but 2.5 years of calm and cygport
changes.

I could try to add base and cross-tools BUILD_REQUIRES/DEPEND to see what
changes, but would prefer that to be knowledge-driven by what affects hints.

Please share what mingw64 package maintainers may have to adjust for new releases.
For comparison, base tools required are shown in:

https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/curl.git;f=curl.cygport;a=blob

which I found there has to be built in a single line, but these builds don't
appear to use of the lib or even -devel packages, only a few ming64-*86*-...
packages, which by definition are all effectively ...-devel.

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in IEC units and prefixes, physical quantities in SI.]
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: calm: cygwin package upload report

Brian Inglis
On 2020-09-07 12:58, Brian Inglis wrote:

> On 2020-09-07 08:04, Jon Turney wrote:
>> On 06/09/2020 18:09, Brian Inglis wrote:
>>> Hi folks,
>>>
>>> Any ideas how to fix these complaints about nonexistent packages?
>>> These mingw64 packages do not yet have any DEPENDS/BUILD_REQUIRES but unsure
>>> what if anything to add other than base with cross tools.
>>>
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>>
>> Your uploaded mingw64-x86_64-curl-7.72.0-1.hint contains:
>>
>> requires: bash mingw64-x86_64-autoconf mingw64-x86_64-automake
>> mingw64-x86_64-libssh2 mingw64-x86_64-libssl mingw64-x86_64-openldap pkg-config
>>
>> so these complaints seems correct.
>>
>> If these aren't coming from a REQUIRES in your .cygport, but are being
>> automatically added by cygport, that would seem to be a bug there.
>>
>> Can you show the .cygport file you are using?
>
> Don't even look at hints to check normally.
>
> Pushed to:
>
> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-x86_64-curl.git;a=blob;f=mingw64-x86_64-curl.cygport
>
> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-i686-curl.git;a=blob;f=mingw64-i686-curl.cygport
>
> minimal changes to version and URLs to https:, but 2.5 years of calm and cygport
> changes.
>
> I could try to add base and cross-tools BUILD_REQUIRES/DEPEND to see what
> changes, but would prefer that to be knowledge-driven by what affects hints.
>
> Please share what mingw64 package maintainers may have to adjust for new releases.
> For comparison, base tools required are shown in:
>
> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/curl.git;f=curl.cygport;a=blob
>
> which I found there has to be built in a single line, but these builds don't
> appear to use of the lib or even -devel packages, only a few ming64-*86*-...
> packages, which by definition are all effectively ...-devel.
Redid cygport package with --debug and attached log, hint, pkg.log, config.log
(1.8MB).
Output .hint requires differs!
Didn't look like it even used Cygwin or mingw64 ssh components, but native
Windows, with generic mingw64 components like headers.

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in IEC units and prefixes, physical quantities in SI.]

cygport-debug-package-hint-requires-mingw64-x86_64-curl.log (184K) Download Attachment
mingw64-x86_64-curl-7.72.0-1.hint (530 bytes) Download Attachment
mingw64-x86_64-curl-7.72.0-1-pkg.log (93K) Download Attachment
config.log (2M) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: calm: cygwin package upload report

Brian Inglis
On 2020-09-07 15:00, Brian Inglis wrote:

> On 2020-09-07 12:58, Brian Inglis wrote:
>> On 2020-09-07 08:04, Jon Turney wrote:
>>> On 06/09/2020 18:09, Brian Inglis wrote:
>>>> Hi folks,
>>>>
>>>> Any ideas how to fix these complaints about nonexistent packages?
>>>> These mingw64 packages do not yet have any DEPENDS/BUILD_REQUIRES but unsure
>>>> what if anything to add other than base with cross tools.
>>>>
>>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>>>
>>> Your uploaded mingw64-x86_64-curl-7.72.0-1.hint contains:
>>>
>>> requires: bash mingw64-x86_64-autoconf mingw64-x86_64-automake
>>> mingw64-x86_64-libssh2 mingw64-x86_64-libssl mingw64-x86_64-openldap pkg-config
>>>
>>> so these complaints seems correct.
>>>
>>> If these aren't coming from a REQUIRES in your .cygport, but are being
>>> automatically added by cygport, that would seem to be a bug there.
>>>
>>> Can you show the .cygport file you are using?
>>
>> Don't even look at hints to check normally.
>>
>> Pushed to:
>>
>> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-x86_64-curl.git;a=blob;f=mingw64-x86_64-curl.cygport
>>
>> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-i686-curl.git;a=blob;f=mingw64-i686-curl.cygport
>>
>> minimal changes to version and URLs to https:, but 2.5 years of calm and cygport
>> changes.
>>
>> I could try to add base and cross-tools BUILD_REQUIRES/DEPEND to see what
>> changes, but would prefer that to be knowledge-driven by what affects hints.
>>
>> Please share what mingw64 package maintainers may have to adjust for new releases.
>> For comparison, base tools required are shown in:
>>
>> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/curl.git;f=curl.cygport;a=blob
>>
>> which I found there has to be built in a single line, but these builds don't
>> appear to use of the lib or even -devel packages, only a few ming64-*86*-...
>> packages, which by definition are all effectively ...-devel.
>
> Redid cygport package with --debug and attached log, hint, pkg.log, config.log
> (1.8MB).
> Output .hint requires differs!
> Didn't look like it even used Cygwin or mingw64 ssh components, but native
> Windows, with generic mingw64 components like headers.

Ping Jon Turney?
Fix?
Suggestions?

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in IEC units and prefixes, physical quantities in SI.]
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: calm: cygwin package upload report

Achim Gratz
Brian Inglis writes:
> Suggestions?

Do you have all mingw64 packages installed that are required due to the
configure statements?  Add the necessary BUILD_REQUIRES so it gets
checked.  I haven't seen the log files you said were attached to some
previous mail.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Factory and User Sound Singles for Waldorf rackAttack:
http://Synth.Stromeko.net/Downloads.html#WaldorfSounds
Reply | Threaded
Open this post in threaded view
|

Re: calm: cygwin package upload report

Brian Inglis
In reply to this post by Brian Inglis
On 2020-09-07 12:58, Brian Inglis wrote:

> On 2020-09-07 08:04, Jon Turney wrote:
>> On 06/09/2020 18:09, Brian Inglis wrote:
>>> Hi folks,
>>>
>>> Any ideas how to fix these complaints about nonexistent packages?
>>> These mingw64 packages do not yet have any DEPENDS/BUILD_REQUIRES but unsure
>>> what if anything to add other than base with cross tools.
>>>
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>>
>> Your uploaded mingw64-x86_64-curl-7.72.0-1.hint contains:
>>
>> requires: bash mingw64-x86_64-autoconf mingw64-x86_64-automake
>> mingw64-x86_64-libssh2 mingw64-x86_64-libssl mingw64-x86_64-openldap pkg-config
>>
>> so these complaints seems correct.
>>
>> If these aren't coming from a REQUIRES in your .cygport, but are being
>> automatically added by cygport, that would seem to be a bug there.
>>
>> Can you show the .cygport file you are using?
>
> Don't even look at hints to check normally.
>
> Pushed to:
>
> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-x86_64-curl.git;a=blob;f=mingw64-x86_64-curl.cygport
>
> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-i686-curl.git;a=blob;f=mingw64-i686-curl.cygport
>
> minimal changes to version and URLs to https:, but 2.5 years of calm and cygport
> changes.
>
> I could try to add base and cross-tools BUILD_REQUIRES/DEPEND to see what
> changes, but would prefer that to be knowledge-driven by what affects hints.
>
> Please share what mingw64 package maintainers may have to adjust for new releases.
> For comparison, base tools required are shown in:
>
> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/curl.git;f=curl.cygport;a=blob
>
> which I found there has to be built in a single line, but these builds don't
> appear to use of the lib or even -devel packages, only a few ming64-*86*-...
> packages, which by definition are all effectively ...-devel.
Redid cygport package with --debug and attached log, hint, pkg.log.
Output .hint requires differs!
Didn't look like it even used Cygwin or mingw64 ssh components, but native
Windows, with generic mingw64 components like headers.

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in IEC units and prefixes, physical quantities in SI.]


cygport-debug-package-hint-requires-mingw64-x86_64-curl.log (184K) Download Attachment
mingw64-x86_64-curl-7.72.0-1.hint (530 bytes) Download Attachment
mingw64-x86_64-curl-7.72.0-1-pkg.log (93K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: calm: cygwin package upload report

Brian Inglis
In reply to this post by Brian Inglis
On 2020-09-07 12:58, Brian Inglis wrote:

> On 2020-09-07 08:04, Jon Turney wrote:
>> On 06/09/2020 18:09, Brian Inglis wrote:
>>> Hi folks,
>>>
>>> Any ideas how to fix these complaints about nonexistent packages?
>>> These mingw64 packages do not yet have any DEPENDS/BUILD_REQUIRES but unsure
>>> what if anything to add other than base with cross tools.
>>>
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' requires:
>>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-autoconf', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-automake', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-libssl', but nothing satisfies that
>>>> ERROR: package 'mingw64-x86_64-curl' version '7.72.0-1' depends:
>>>> 'mingw64-x86_64-openldap', but nothing satisfies that
>>
>> Your uploaded mingw64-x86_64-curl-7.72.0-1.hint contains:
>>
>> requires: bash mingw64-x86_64-autoconf mingw64-x86_64-automake
>> mingw64-x86_64-libssh2 mingw64-x86_64-libssl mingw64-x86_64-openldap pkg-config
>>
>> so these complaints seems correct.
>>
>> If these aren't coming from a REQUIRES in your .cygport, but are being
>> automatically added by cygport, that would seem to be a bug there.
>>
>> Can you show the .cygport file you are using?
>
> Don't even look at hints to check normally.
>
> Pushed to:
>
> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-x86_64-curl.git;a=blob;f=mingw64-x86_64-curl.cygport
>
> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/mingw64-i686-curl.git;a=blob;f=mingw64-i686-curl.cygport
>
> minimal changes to version and URLs to https:, but 2.5 years of calm and cygport
> changes.
>
> I could try to add base and cross-tools BUILD_REQUIRES/DEPEND to see what
> changes, but would prefer that to be knowledge-driven by what affects hints.
>
> Please share what mingw64 package maintainers may have to adjust for new releases.
> For comparison, base tools required are shown in:
>
> https://cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/curl.git;f=curl.cygport;a=blob
>
> which I found there has to be built in a single line, but these builds don't
> appear to use of the lib or even -devel packages, only a few ming64-*86*-...
> packages, which by definition are all effectively ...-devel.
Redid cygport package with --debug and attached config.log (1.8MB).
Output .hint requires differs!
Didn't look like it even used Cygwin or mingw64 ssh components, but native
Windows, with generic mingw64 components like headers.

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in IEC units and prefixes, physical quantities in SI.]


config.log (2M) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: calm: cygwin package upload report

Brian Inglis
In reply to this post by Achim Gratz
On 2020-09-13 22:52, ASSI wrote:
> Brian Inglis writes:
>> Suggestions?
>
> Do you have all mingw64 packages installed that are required due to the
> configure statements?  Add the necessary BUILD_REQUIRES so it gets
> checked.  I haven't seen the log files you said were attached to some
> previous mail.

Reposted 2020-09-07 21:00+0000 with 4 attachments:

https://cygwin.com/pipermail/cygwin-apps/2020-September/040490.html

as 2 posts: first with 3 smaller, last with 1 large attachment.

Will recheck dependencies, add list, and redo.

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in IEC units and prefixes, physical quantities in SI.]