Autoconf files need v2.69

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Autoconf files need v2.69

Cygwin list mailing list
Currently the autoconf files in newlib-cygwin repo are in 2.64 version
but the latest autoconf package is version 2.69. So, autoreconf
command shows errors. Possible diff attached.

--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple

newlib-cygwin-update-autoconf.diff (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Autoconf files need v2.69

Corinna Vinschen-2
On Nov 18 15:06, Biswapriyo Nath via Cygwin wrote:
> Currently the autoconf files in newlib-cygwin repo are in 2.64 version
> but the latest autoconf package is version 2.69. So, autoreconf
> command shows errors. Possible diff attached.

We can update to 2.68, but not 2.69.  Newlib still requires older
autotools due to some ancient Cygnus stuff not supported anymore in
newer autotools.

Care to fix your patch up and send it in `git format-patch' format to
the newlib AT sourceware DOT org mailing list?


Thanks,
Corinna
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: Autoconf files need v2.69

Cygwin list mailing list
I am not familiar with newlib. Please feel free whatever you want to
do with my previously provided diff. Also my previous question is
unanswered.
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple
Reply | Threaded
Open this post in threaded view
|

Re: Autoconf files need v2.69

Brian Inglis
On 2020-11-18 11:19, Biswapriyo Nath via Cygwin wrote:
> I am not familiar with newlib. Please feel free whatever you want to
> do with my previously provided diff. Also my previous question is
> unanswered.

Cygwin provides autoconf 2.69 but it's what builds the package that counts, also
perhaps what is available in the cross-build toolchains supported by newlib for
some platforms with limited support.

Some packages or platforms may have maintainers that are not comfortable with or
have difficulty updating their autotools infrastructure, so that part of the
process languishes: some packages are notorious for how old their autotools
requirements are.

Some packages will not build if autoreconfiged, why old releases are still
supported: autoconf/autoheader/autoreconf/autoscan/autoupdate 2.13-2.69,
automake 1.4-1.16.

--
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in binary units and prefixes, physical quantities in SI.]
--
Problem reports:      https://cygwin.com/problems.html
FAQ:                  https://cygwin.com/faq/
Documentation:        https://cygwin.com/docs.html
Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple