[ATTN MAINTAINER] mercurial with python3

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ATTN MAINTAINER] mercurial with python3

cygwin-apps mailing list
Hi Jari,
can you provide a test version that works with python3.8 ?

----------------------------------------------------------
$ hg clone http://hg.code.sf.net/p/graphicsmagick/code GM
Traceback (most recent call last):
   File "/usr/bin/hg", line 43, in <module>
     dispatch.run()
   File "/usr/lib/python3.8/importlib/util.py", line 245, in
__getattribute__
     self.__spec__.loader.exec_module(self)
   File "<frozen importlib._bootstrap_external>", line 783, in exec_module
   File "<frozen importlib._bootstrap>", line 219, in
_call_with_frames_removed
   File "/usr/lib/python2.7/site-packages/mercurial/dispatch.py", line
22, in <module>
...
     import http.cookiejar as cookielib
   File "/usr/lib/python3.8/importlib/util.py", line 245, in
__getattribute__
     self.__spec__.loader.exec_module(self)
   File "/usr/lib/python2.7/site-packages/http/__init__.py", line 7, in
<module>
     raise ImportError('This package should not be accessible on Python 3. '
ImportError: This package should not be accessible on Python 3. Either
you are trying to run from the python-future src folder or your
installation of python-future is corrupted.
-----------------------------------------------------------------------------

the usage of

$ alternatives --config python

to set for python2.7 works as expected for the time being.

Regards
Marco