Quantcast

[ANNOUNCEMENT] test: icu-59.1-1

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[ANNOUNCEMENT] test: icu-59.1-1

Ken Brown-6
The following packages have been uploaded to the Cygwin distribution:

* libicu59-59.1-1
* libicu-devel-59.1-1
* icu-doc-59.1-1

ICU is a mature, widely used set of C/C++ and Java libraries providing
Unicode and Globalization support for software applications.  ICU is
widely portable and gives applications the same results on all
platforms and between C/C++ and Java software.

This is an update to the latest upstream release.  There are major
changes in this release that will make ICU easier to use but require
changes in projects using ICU.  In particular, ICU now requires C++11,
so packages using ICU may need to add -std=c++11 or -std=gnu++11 to
CXXFLAGS.  See

  http://site.icu-project.org/download/59

for further details.

I'm making this a test release to give other maintainers time to
adapt to the changes.  If no problems are reported within a few weeks,
I'll promote it to current.

Ken Brown
Cygwin's ICU maintainer

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Loading...