[ANNOUNCEMENT] Updated: octave-5.1.0-1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[ANNOUNCEMENT] Updated: octave-5.1.0-1

marco atzeri-4
New versions 5.1.0-1 of

    octave
    octave-devel
    octave-doc

are available in the Cygwin distribution:

CHANGES
Latest upstream  release.
https://www.gnu.org/software/octave/news/release/2019/03/01/octave-5.1-released.html

Full changes:
https://www.gnu.org/software/octave/NEWS-5.1.html

GENERAL NOTE
there are 2 octave main binaries with multiple graphic properties

         octave          command line with full plotting capabilities

         octave --gui    graphical interface

         octave-cli      command line inteface with plotting
                         restricted to fltk and gnuplot

Of the 3 graphics toolkit fltk, gnuplot and qt
         fltk is the worst performing on cygwin
         gnuplot the lightest
         qt the most graphic rich
OCTAVE-FORGE NOTE
You need to install with setup the specific forge package
you are looking for.

The update of the global pkg database is managed
by cygwin setup during the postinstall phase.
A semaphore system is in place to update the database only when needed
and just one time, also when multiple forge packages are added or removed.

DESCRIPTION
The GNU Octave language for numerical computations is a (mostly
Matlab (R) compatible) high-level language, primarily intended
for numerical computations.  It provides a convenient command-line
interface for solving linear and nonlinear problems numerically.

HOMEPAGE
http://www.gnu.org/software/octave/

Marco Atzeri

If you have questions or comments, please send them to the
cygwin mailing list at: cygwin (at) cygwin (dot) com .

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: [ANNOUNCEMENT] Updated: octave-5.1.0-1

Takashi Yano
On Mon, 13 Jan 2020 21:02:46 +0100
Marco Atzeri wrote:
> New versions 5.1.0-1 of
>     octave
>     octave-devel
>     octave-doc
> are available in the Cygwin distribution:

After upgrading octave and octave-devel to 5.1.0-1,
mkoctfile stopped working with error:
/usr/lib/gcc/i686-pc-cygwin/7.4.0/../../../../i686-pc-cygwin/bin/ld: cannot find -loctinterp
/usr/lib/gcc/i686-pc-cygwin/7.4.0/../../../../i686-pc-cygwin/bin/ld: cannot find -loctave
collect2: error: ld returned 1 exit status

It seems that option -L/usr/lib/octave/5.1.0, which should be added
by default, is missing.

If -L option is added manually, it works as expected.

--
Takashi Yano <[hidden email]>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

Reply | Threaded
Open this post in threaded view
|

Re: [ANNOUNCEMENT] Updated: octave-5.1.0-1

marco atzeri-4
On Wed, 15 Jan 2020, 11:09 Takashi Yano, wrote:

> On Mon, 13 Jan 2020 21:02:46 +0100
> Marco Atzeri wrote:
> > New versions 5.1.0-1 of
> >     octave
> >     octave-devel
> >     octave-doc
> > are available in the Cygwin distribution:
>
> After upgrading octave and octave-devel to 5.1.0-1,
> mkoctfile stopped working with error:
> /usr/lib/gcc/i686-pc-cygwin/7.4.0/../../../../i686-pc-cygwin/bin/ld:
> cannot find -loctinterp
> /usr/lib/gcc/i686-pc-cygwin/7.4.0/../../../../i686-pc-cygwin/bin/ld:
> cannot find -loctave
> collect2: error: ld returned 1 exit status
>
> It seems that option -L/usr/lib/octave/5.1.0, which should be added
> by default, is missing.
>
> If -L option is added manually, it works as expected.
>
> --
> Takashi
>

This is an upstream change, it was a surprise also for me the first time.
You can use pkg-config for a proper settings of LDFLAGS and use it in your
makefiles.
Most forge packages were modified to handle this change.

Regards
Marco

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple